summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <smitdane@gmail.com>2010-07-16 21:45:06 -0400
committerDane Smith <smitdane@gmail.com>2010-07-16 21:45:06 -0400
commite3d40e6d354fbdd02123c17ae37750134877f29d (patch)
tree09d768bb16d241123eda9802445eb9c14c2bf716 /app-backup/nssbackup/nssbackup-0.2.1.ebuild
downloadsmithdanea-e3d40e6d354fbdd02123c17ae37750134877f29d.tar.gz
smithdanea-e3d40e6d354fbdd02123c17ae37750134877f29d.tar.bz2
smithdanea-e3d40e6d354fbdd02123c17ae37750134877f29d.zip
Intial commit for my public overlay.
All working projects.
Diffstat (limited to 'app-backup/nssbackup/nssbackup-0.2.1.ebuild')
-rw-r--r--app-backup/nssbackup/nssbackup-0.2.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-backup/nssbackup/nssbackup-0.2.1.ebuild b/app-backup/nssbackup/nssbackup-0.2.1.ebuild
new file mode 100644
index 0000000..2e5f45b
--- /dev/null
+++ b/app-backup/nssbackup/nssbackup-0.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.5"
+
+inherit distutils python versionator
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Fork of the sbackup project with better user interaction"
+HOMEPAGE="https://launchpad.net/nssbackup"
+SRC_URI="http://launchpad.net/${PN}/${MY_PV}/${MY_PV}/+download/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS="HACKING"
+
+DEPEND="dev-python/setuptools"
+RDEPEND="dev-python/notify-python
+ dev-python/pexpect
+ dev-python/pygtk
+ net-fs/curlftpfs
+ sys-devel/gettext
+ sys-fs/fuse
+ sys-fs/sshfs-fuse"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_compile(){
+ emake DISTDIR=/usr PREFIX=/usr || die
+ distutils_src_compile
+}
+
+src_install(){
+ local script
+
+ distutils_src_install
+ cd scripts || die
+ for script in *.py; do
+ newbin ${script} ${script/.py/} || die
+ done
+}
+
+pkg_postinst(){
+ elog
+ elog "If you want better gnome integration you may"
+ elog "wish to install dev-python/gnome-python"
+ elog
+
+}