summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <smitdane@gmail.com>2010-08-09 20:23:03 -0400
committerDane Smith <smitdane@gmail.com>2010-08-09 20:23:03 -0400
commit715fb951d6eb85a7b286431fd3dae5e928ca6e12 (patch)
tree1e4f6a74c4ff7fab675f93ad2f5528bd4ea49eab /dev-libs/nettle/nettle-1.15.ebuild
parentMake my life easier (diff)
downloadsmithdanea-715fb951d6eb85a7b286431fd3dae5e928ca6e12.tar.gz
smithdanea-715fb951d6eb85a7b286431fd3dae5e928ca6e12.tar.bz2
smithdanea-715fb951d6eb85a7b286431fd3dae5e928ca6e12.zip
New ebuild for nettle
Diffstat (limited to 'dev-libs/nettle/nettle-1.15.ebuild')
-rw-r--r--dev-libs/nettle/nettle-1.15.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/nettle/nettle-1.15.ebuild b/dev-libs/nettle/nettle-1.15.ebuild
new file mode 100644
index 0000000..4f4b99d
--- /dev/null
+++ b/dev-libs/nettle/nettle-1.15.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-1.15.ebuild,v 1.6 2007/12/11 10:03:54 vapier Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="cryptographic library that is designed to fit easily in any context"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc s390 sparc x86 ~x86-fbsd"
+IUSE="gmp ssl"
+
+DEPEND="gmp? ( dev-libs/gmp )
+ ssl? ( dev-libs/openssl )
+ !<dev-libs/lsh-1.4.3-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.14-make-as-needed.patch"
+ sed -i \
+ -e '/CFLAGS/s:-ggdb3::' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --enable-shared \
+ $(use_enable ssl openssl) \
+ $(use_enable gmp public-key) \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}