summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/pyrit/ChangeLog10
-rw-r--r--app-crypt/pyrit/Manifest3
-rw-r--r--app-crypt/pyrit/pyrit-0.3.0.ebuild28
3 files changed, 41 insertions, 0 deletions
diff --git a/app-crypt/pyrit/ChangeLog b/app-crypt/pyrit/ChangeLog
new file mode 100644
index 0000000..b93e29a
--- /dev/null
+++ b/app-crypt/pyrit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-crypt/pyrit
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pyrit-0.3.0 (11 Aug 2010)
+
+ 11 Aug 2010; Dane Smith (c1pher) <smithdanea@gmail.com>
+ +pyrit-0.3.0.ebuild:
+ New ebuild for pyrit-0.3.0 wrt bug 309813. Thanks to Andreis Vinogradovs.
+
diff --git a/app-crypt/pyrit/Manifest b/app-crypt/pyrit/Manifest
new file mode 100644
index 0000000..06f8673
--- /dev/null
+++ b/app-crypt/pyrit/Manifest
@@ -0,0 +1,3 @@
+DIST pyrit-0.3.0.tar.gz 136316 RMD160 2cd79e0d8d811515e44ca36d6217a75317d30768 SHA1 c164e84b6ea27fafccbf3d59645b2c616ab1ce2a SHA256 398b956d27cd863318adfa79c3fbbab2d3ccdf6f509452968368b8be72ccd975
+EBUILD pyrit-0.3.0.ebuild 589 RMD160 dfd0b7565a3404749db1180039b360ebff40a8cd SHA1 a7490f6ce4d00fb295d2eefa6b425128852ca3a3 SHA256 f1093ca82d96b34dd3c640cc90cf2e68d571c6d844f979a0ccdfa86ff0e327c4
+MISC ChangeLog 302 RMD160 3283edab79d422d4c12df63d3480347ded662d6e SHA1 e57252ec28ffdbb0d279d522bc1fd2fd7e5355ff SHA256 28244a5a9f4484b87cdb3f3a03a15a2fd122e3bf233db7df0c6e52bc7b1278b1
diff --git a/app-crypt/pyrit/pyrit-0.3.0.ebuild b/app-crypt/pyrit/pyrit-0.3.0.ebuild
new file mode 100644
index 0000000..85bc510
--- /dev/null
+++ b/app-crypt/pyrit/pyrit-0.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python distutils flag-o-matic
+
+DESCRIPTION="GPU-accelerated attack against WPA-PSK authentication"
+HOMEPAGE="http://pyrit.googlecode.com"
+SRC_URI="http://pyrit.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ python_copy_sources
+ distutils_src_prepare
+}