aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2017-05-16 10:47:35 +0100
committerStuart Shelton <stuart@shelton.me>2017-05-16 10:47:35 +0100
commit5423e8ac1c397b4353f3f37c89c606c388d422dc (patch)
treecda4b6946e0ad4760c057999e151293db9ec199a
parentUpdate net-misc/wget-1.19.1-r1 (diff)
downloadsrcshelton-5423e8ac1c397b4353f3f37c89c606c388d422dc.tar.gz
srcshelton-5423e8ac1c397b4353f3f37c89c606c388d422dc.tar.bz2
srcshelton-5423e8ac1c397b4353f3f37c89c606c388d422dc.zip
Add net-analyzer/ntop-5.0.1-r3
-rw-r--r--net-analyzer/ntop/Manifest1
-rw-r--r--net-analyzer/ntop/ntop-5.0.1-r3.ebuild142
2 files changed, 143 insertions, 0 deletions
diff --git a/net-analyzer/ntop/Manifest b/net-analyzer/ntop/Manifest
index 1b76a059..9930eaa3 100644
--- a/net-analyzer/ntop/Manifest
+++ b/net-analyzer/ntop/Manifest
@@ -10,3 +10,4 @@ AUX ntop-update-geoip-db 492 SHA256 3604d0a728b203211fab05eca829a7e93bc05c04f252
DIST ntop-5.0.1.tar.gz 40133867 SHA256 7e8e84cb14d2173beaca4d4cb991a14d84a4bef84ec37b2276bc363f45c52ef8 SHA512 f52c40e6c00c8d2f46b68078c5f9aef8ed78670f92a0a81f66f2f44c71d41bc4c001b4550f19b71c546f7c07cbbed15e0aa1ee13873ac63a11678bf2b8483f2a WHIRLPOOL aa20b6529f343f6f57fc1d880c8cf07cd11720c6fe8c968359ff1e16b77fe3f4c6df1ed83a184e580d6ef7f5eff6d245b2971c17a7dd674c12325f21029f64ee
EBUILD ntop-5.0.1-r1.ebuild 3222 SHA256 14f68f5056fa0e3837365665d0122f60c2fc44908866177fec112df564ee7dce SHA512 47f5df5903c51923373657b427791f64550d40b3214212a8ccb06d0ee9906edd92fee1abc5131c625389ef54d08052fd9305f8d7c14590a10970f44ac3fd00be WHIRLPOOL 26013f2a1409aed3a2007d6283d6614a145d8d6aaa62ab71d0982f6c84a4dfa0942808798b36d387a8c45ec8a6c9e40d84d3c741630905fb0c60f54e623a0b90
EBUILD ntop-5.0.1-r2.ebuild 3148 SHA256 1d6cc1f5f19044d24a59c26c39024acab23d7324449f07f9565d871032b0d811 SHA512 d61de28e1b408380d2f170c100d6377c8e28eed804354623aaf22c29df90de635cbba5462da62515c2248a55dc967689d50da0a14b22fcaa7999fb4d368bcb55 WHIRLPOOL e6706c5ce0d8ba220d6d16beeb4781f1ec7d12472e550ddc4b3b751cd0bbf889249221bef393782aeab16d4d128872abcd881dcc7b068e2affb732665795e412
+EBUILD ntop-5.0.1-r3.ebuild 3220 SHA256 62b1b5ef834f16c8a1cd8ebe66f38eca66b8e53aed93c3b57f20fb2a3559ca4d SHA512 eae3ac98a98247e05283e79e516e914ce4ca69a6d5f5ed6b8a91b74809b3cdddd3623c13d04f095ec4928eae77e39265bdf1fa323582a984cf3022edd3c1c38d WHIRLPOOL a787e8655c5457605d9c9e5ed04eb83c13814b845978fd05102610ebd1f88d0c6adb80c617fdf6187d70ca8dcb40591fb479821b70fbd49b32f0eda9c2934a61
diff --git a/net-analyzer/ntop/ntop-5.0.1-r3.ebuild b/net-analyzer/ntop/ntop-5.0.1-r3.ebuild
new file mode 100644
index 00000000..351bdaf4
--- /dev/null
+++ b/net-analyzer/ntop/ntop-5.0.1-r3.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multilib user python-single-r1
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="http://www.ntop.org/products/ntop/"
+SRC_URI="mirror://sourceforge/ntop/ntop/Stable/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libressl snmp ssl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ dev-lang/lua:=
+ dev-lang/perl
+ dev-libs/geoip
+ dev-libs/libevent
+ media-libs/gd
+ media-libs/libpng:0=
+ net-analyzer/rrdtool[graph]
+ net-libs/libpcap
+ snmp? ( net-analyzer/net-snmp[ipv6] )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ sys-libs/gdbm
+ sys-libs/zlib
+ virtual/awk
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ >=sys-devel/libtool-1.5.26
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ app-arch/gzip
+ dev-libs/glib:2
+ dev-python/mako
+ media-gfx/graphviz
+ net-misc/wget
+"
+
+pkg_setup() {
+ enewgroup ntop
+ enewuser ntop -1 -1 /var/lib/ntop ntop
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-includes.patch \
+ "${FILESDIR}"/${P}-librrd.patch
+
+ cp /usr/share/aclocal/libtool.m4 libtool.m4.in
+ cat acinclude.m4.in libtool.m4.in acinclude.m4.ntop > acinclude.m4
+ eautoreconf
+
+ # The build system is a complete mess, so apply a configure patch here
+ # instead of patching configure.in above
+ epatch "${FILESDIR}"/${P}-INCS.patch
+
+ # Stop make from doing autotools stuff
+ sed -i -e '/missing --run echo/s|=.*|= true|g' Makefile.in || die
+}
+
+src_configure() {
+ export \
+ ac_cv_header_glib_h=no \
+ ac_cv_header_glibconfig_h=no \
+ ac_cv_header_gdome_h=no \
+ ac_cv_lib_glib_g_date_julian=no \
+ ac_cv_lib_xml2_xmlCheckVersion=no \
+ ac_cv_lib_gdome_gdome_di_saveDocToFile=no
+
+ pushd nDPI >/dev/null || die
+ econf
+ popd &>/dev/null || die
+
+ if has_version '<net-analyzer/rrdtool-1.6'; then
+ export RRD_LIB=-lrrd_th
+ else
+ export RRD_LIB=-lrrd
+ fi
+
+ econf \
+ $(use_enable snmp) \
+ $(use_with ssl) \
+ --with-rrd-home=/usr/$(get_libdir)
+}
+
+src_compile() {
+ pushd nDPI >/dev/null || die
+ emake
+ popd &>/dev/null || die
+
+ emake
+}
+
+src_install() {
+ LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
+
+ emake DESTDIR="${D}" install
+
+ keepdir /var/lib/ntop
+
+ insinto /var/lib/ntop
+ gunzip 3rd_party/GeoIPASNum.dat.gz
+ gunzip 3rd_party/GeoLiteCity.dat.gz
+ local f
+ for f in GeoIPASNum.dat GeoLiteCity.dat; do
+ # Don't install included GeoIP files if newer versions are available
+ [ -f "${ROOT}/var/lib/ntop/${f}" ] ||
+ doins "3rd_party/${f}"
+ done
+
+ dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
+ dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
+
+ newinitd "${FILESDIR}"/ntop-initd-r1 ntop
+ newconfd "${FILESDIR}"/ntop-confd ntop
+
+ exeinto /etc/cron.monthly
+ doexe "${FILESDIR}"/ntop-update-geoip-db
+}
+
+pkg_postinst() {
+ fowners ntop:ntop /var/lib/ntop
+ fperms 750 /var/lib/ntop
+
+ elog "If this is the first time you install ntop, you need to run"
+ elog "following command before starting ntop service:"
+ elog " ntop --set-admin-password"
+}