summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYamashita Takao <tjy1965@gmail.com>2010-10-25 10:13:41 +0900
committerYamashita Takao <tjy1965@gmail.com>2010-10-25 10:13:41 +0900
commitc12e7224420b20021ce30a88394d29b16e2023de (patch)
treecb21de161ed9ed52ca43234716ae722d8af8b518 /app-emacs/ddskk/ddskk-14.1.ebuild
parentadd app-i18n/ibus-skk/ibus-skk-9999.ebuild (diff)
downloadtjy1965-c12e7224420b20021ce30a88394d29b16e2023de.tar.gz
tjy1965-c12e7224420b20021ce30a88394d29b16e2023de.tar.bz2
tjy1965-c12e7224420b20021ce30a88394d29b16e2023de.zip
add:app-emacs/ddskk/ddskk-14.1.ebuild
Diffstat (limited to 'app-emacs/ddskk/ddskk-14.1.ebuild')
-rw-r--r--app-emacs/ddskk/ddskk-14.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/ddskk/ddskk-14.1.ebuild b/app-emacs/ddskk/ddskk-14.1.ebuild
new file mode 100644
index 0000000..a99e75e
--- /dev/null
+++ b/app-emacs/ddskk/ddskk-14.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit elisp
+
+DESCRIPTION="One Japanese input methods on Emacs"
+HOMEPAGE="http://openlab.ring.gr.jp/skk/"
+SRC_URI="http://openlab.ring.gr.jp/skk/maintrunk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-emacs/apel-10.7"
+RDEPEND="${DEPEND}
+ || ( app-i18n/skk-jisyo virtual/skkserv )"
+
+SITEFILE=50ddskk-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ find . -type f | xargs sed -i -e 's%/usr/local%/usr%g' || die
+}
+
+src_compile() {
+ emake < /dev/null || die "emake failed"
+ emake info < /dev/null || die "emake info failed"
+ #cd nicola
+ #make < /dev/null || die
+ cd "${S}/tut-code"
+ BYTECOMPFLAGS="${BYTECOMPFLAGS} -L .."
+ elisp-compile *.el || die "elisp-compile failed"
+}
+
+src_install () {
+ elisp-install ${PN} *.el* nicola/*.el* tut-code/*.el* || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
+
+ insinto /usr/share/skk
+ doins etc/*SKK.tut* etc/skk.xpm
+
+ dodoc READMEs/* ChangeLog*
+ doinfo doc/skk.info*
+
+ #docinto nicola
+ #dodoc nicola/ChangeLog* nicola/README*
+ docinto tut-code
+ dodoc tut-code/README.tut
+}