summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Crandall <triquetra@triquetradevelopment.com>2016-01-17 18:25:46 -0600
committerDavid Crandall <triquetra@triquetradevelopment.com>2016-01-17 18:25:46 -0600
commit53aa9527792122cd9f398e26b9a6ee7da22f6c5c (patch)
treee642e43b4b2f4e7fec4e7aa5d48d338abb7496e5
parentAdded hg-git 0.8.4 ebuild (diff)
downloadtriquetra-53aa9527792122cd9f398e26b9a6ee7da22f6c5c.tar.gz
triquetra-53aa9527792122cd9f398e26b9a6ee7da22f6c5c.tar.bz2
triquetra-53aa9527792122cd9f398e26b9a6ee7da22f6c5c.zip
Added ebuilds for rcm
-rw-r--r--app-admin/rcm/Manifest2
-rw-r--r--app-admin/rcm/rcm-1.2.3.ebuild37
-rw-r--r--app-admin/rcm/rcm-1.3.0.ebuild37
3 files changed, 76 insertions, 0 deletions
diff --git a/app-admin/rcm/Manifest b/app-admin/rcm/Manifest
new file mode 100644
index 0000000..8ef4c34
--- /dev/null
+++ b/app-admin/rcm/Manifest
@@ -0,0 +1,2 @@
+EBUILD rcm-1.2.3.ebuild 652 SHA256 bf4e2988b57afcba2f785abf8c6f5507c56d7debf5d24b4858c33d49da342b64 SHA512 ff2e30a04d75024bd1c71506753706b54e97e4a8cacc677b4028e092c4ac564027f70be89cb443b1e2792270a910609ffc97f7708ad2d676bbef95c8805eca54 WHIRLPOOL 0f584d602993b2c3ca13b8485640035fb7d3c9cf016f9fa2b3701fcbdf3ef774f7572d511d062a43b3f1d5925158f19bb8514656fa56443fedd946889bca429b
+EBUILD rcm-1.3.0.ebuild 652 SHA256 bf4e2988b57afcba2f785abf8c6f5507c56d7debf5d24b4858c33d49da342b64 SHA512 ff2e30a04d75024bd1c71506753706b54e97e4a8cacc677b4028e092c4ac564027f70be89cb443b1e2792270a910609ffc97f7708ad2d676bbef95c8805eca54 WHIRLPOOL 0f584d602993b2c3ca13b8485640035fb7d3c9cf016f9fa2b3701fcbdf3ef774f7572d511d062a43b3f1d5925158f19bb8514656fa56443fedd946889bca429b
diff --git a/app-admin/rcm/rcm-1.2.3.ebuild b/app-admin/rcm/rcm-1.2.3.ebuild
new file mode 100644
index 0000000..d1e71df
--- /dev/null
+++ b/app-admin/rcm/rcm-1.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Copyright 2014 Anton Ilin
+# Distributed under the terms of the MIT LICENSE
+# $Header: $
+
+EAPI=5
+
+inherit autotools eutils git-2
+
+DESCRIPTION="Management suite for dotfiles"
+HOMEPAGE="https://github.com/thoughtbot/rcm"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+EGIT_REPO_URI="https://github.com/thoughtbot/rcm.git"
+EGIT_COMMIT="v${PV}"
+
+DEPEND="dev-ruby/mustache"
+
+src_prepare() {
+ eautoreconf
+ maint/autocontrib man/rcm.7.mustache
+}
+
+src_configure() {
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
diff --git a/app-admin/rcm/rcm-1.3.0.ebuild b/app-admin/rcm/rcm-1.3.0.ebuild
new file mode 100644
index 0000000..d1e71df
--- /dev/null
+++ b/app-admin/rcm/rcm-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Copyright 2014 Anton Ilin
+# Distributed under the terms of the MIT LICENSE
+# $Header: $
+
+EAPI=5
+
+inherit autotools eutils git-2
+
+DESCRIPTION="Management suite for dotfiles"
+HOMEPAGE="https://github.com/thoughtbot/rcm"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+EGIT_REPO_URI="https://github.com/thoughtbot/rcm.git"
+EGIT_COMMIT="v${PV}"
+
+DEPEND="dev-ruby/mustache"
+
+src_prepare() {
+ eautoreconf
+ maint/autocontrib man/rcm.7.mustache
+}
+
+src_configure() {
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+