summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Crandall <triquetra@triquetradevelopment.com>2016-01-17 17:58:14 -0600
committerDavid Crandall <triquetra@triquetradevelopment.com>2016-01-17 17:58:14 -0600
commit230413ddf23d166989984f3ed9e7f1e9c5812dc9 (patch)
treeb8f549251c7c30dec98f57bdfea722d65c032bc6 /dev-vcs/hg-git/hg-git-0.8.4.ebuild
parentRemoved e-builds now available and maintained elsewhere. (diff)
downloadtriquetra-230413ddf23d166989984f3ed9e7f1e9c5812dc9.tar.gz
triquetra-230413ddf23d166989984f3ed9e7f1e9c5812dc9.tar.bz2
triquetra-230413ddf23d166989984f3ed9e7f1e9c5812dc9.zip
Added hg-git 0.8.4 ebuild
Diffstat (limited to 'dev-vcs/hg-git/hg-git-0.8.4.ebuild')
-rw-r--r--dev-vcs/hg-git/hg-git-0.8.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/hg-git-0.8.4.ebuild b/dev-vcs/hg-git/hg-git-0.8.4.ebuild
new file mode 100644
index 0000000..e2c3fb3
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.8.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="http://hg-git.github.io https://pypi.python.org/pypi/hg-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-1.9.3[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.9.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"