summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/gentool/gentool-0.1.12.ebuild')
-rw-r--r--app-admin/gentool/gentool-0.1.12.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/gentool/gentool-0.1.12.ebuild b/app-admin/gentool/gentool-0.1.12.ebuild
new file mode 100644
index 0000000..6296f4b
--- /dev/null
+++ b/app-admin/gentool/gentool-0.1.12.ebuild
@@ -0,0 +1,46 @@
+EAPI=2
+inherit eutils
+DESCRIPTION="gentoo system management"
+HOMEPAGE=""
+SRC_URI="http://www.aperiplus.co.uk/downloads/src/${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+
+#DEPEND=""
+
+RDEPEND="net-misc/rsync
+ sys-boot/grub
+ >=app-misc/bashfun-0.1.4
+ net-misc/htpdate"
+
+src_install() {
+ dodir '/opt/gentool' || die "out of cheese error 1"
+ insinto '/opt/gentool' || die "out of cheese error 2"
+ cp -ar ${S}'/opt/gentool/'* ${D}'/opt/gentool/' || die "out of cheese error 3"
+ dodir '/etc/gentool' || die "out of cheese error 4"
+ insinto '/etc/gentool' || die "out of cheese error 5"
+ doins ${S}'/etc/gentool/config.sh' || die "out of cheese error 6"
+ doenvd ${S}'/etc/env.d/99gentool-env' || die "out of cheese error 7"
+}
+
+pkg_postinst() {
+ if [ ! -f /opt/bin/gentool ]
+ then
+ cd /opt/bin
+ ln -s /opt/gentool/bin/gentool.sh gentool
+ fi
+
+ path_minus_opt_bin=`echo $PATH | sed 's~/opt/bin:~~g'`
+ if [ $PATH = $path_minus_opt_bin ]
+ then
+ ewarn
+ ewarn '/opt/bin is not in your $PATH!'
+ ewarn '(gentool is installed at /opt/bin/gentool)'
+ ewarn
+ fi
+ ewarn
+ ewarn 'you may want to edit /etc/gentool/config.sh now - just follow instructions in the file'
+ ewarn
+}