summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/gentool/gentool-0.2.3.ebuild')
-rw-r--r--app-admin/gentool/gentool-0.2.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/gentool/gentool-0.2.3.ebuild b/app-admin/gentool/gentool-0.2.3.ebuild
new file mode 100644
index 0000000..51131fa
--- /dev/null
+++ b/app-admin/gentool/gentool-0.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="gentoo system management"
+HOMEPAGE=""
+SRC_URI="http://www.aperiplus.co.uk/downloads/src/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-misc/bashfun-0.1.4
+ net-misc/htpdate
+ net-misc/rsync
+ sys-boot/grub"
+
+#DEPEND=""
+
+src_install() {
+ dosym /opt/gentool/bin/gentool.sh /opt/bin/gentool
+ insinto '/opt/gentool'
+ doins -r "${S}/opt/gentool"
+ dodir '/etc/gentool'
+ insinto '/etc/gentool'
+ doins "${S}/etc/gentool/config.sh"
+ doenvd "${S}/etc/env.d/99gentool-env"
+}
+
+pkg_postinst() {
+ elog
+ elog 'you may want to edit /etc/gentool/config.sh now - just follow instructions in the file'
+ elog
+}