summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/php/files/5.0.0')
-rw-r--r--dev-lang/php/files/5.0.0/CVS/Entries8
-rw-r--r--dev-lang/php/files/5.0.0/CVS/Repository1
-rw-r--r--dev-lang/php/files/5.0.0/CVS/Root1
-rw-r--r--dev-lang/php/files/5.0.0/CVS/Tag1
-rw-r--r--dev-lang/php/files/5.0.0/php5-hphp-acinclude.patch19
-rw-r--r--dev-lang/php/files/5.0.0/php5-imap-symlink.diff15
-rw-r--r--dev-lang/php/files/5.0.0/php5-iodbc-config.diff14
-rw-r--r--dev-lang/php/files/5.0.0/php5-libtool-1.5.patch19
-rw-r--r--dev-lang/php/files/5.0.0/php5.0.4-pcre-security.patch38
-rw-r--r--dev-lang/php/files/5.0.0/php5.0.4-xmlrcp-ccode.diff23
-rw-r--r--dev-lang/php/files/5.0.0/php5.0.5-obj-serialize.patch42
11 files changed, 181 insertions, 0 deletions
diff --git a/dev-lang/php/files/5.0.0/CVS/Entries b/dev-lang/php/files/5.0.0/CVS/Entries
new file mode 100644
index 0000000..6061dcf
--- /dev/null
+++ b/dev-lang/php/files/5.0.0/CVS/Entries
@@ -0,0 +1,8 @@
+/php5-hphp-acinclude.patch/1.1/Thu Sep 8 20:47:34 2005/-ko/T1.1
+/php5-imap-symlink.diff/1.1/Sun Sep 4 16:58:08 2005//T1.1
+/php5-iodbc-config.diff/1.1/Sun Sep 4 16:58:08 2005//T1.1
+/php5-libtool-1.5.patch/1.1/Sun Sep 18 13:21:54 2005//T1.1
+/php5.0.4-pcre-security.patch/1.1/Sun Sep 18 13:21:54 2005//T1.1
+/php5.0.4-xmlrcp-ccode.diff/1.1/Sun Sep 18 13:21:54 2005//T1.1
+/php5.0.5-obj-serialize.patch/1.1/Sun Sep 18 13:21:54 2005//T1.1
+D
diff --git a/dev-lang/php/files/5.0.0/CVS/Repository b/dev-lang/php/files/5.0.0/CVS/Repository
new file mode 100644
index 0000000..ce0f757
--- /dev/null
+++ b/dev-lang/php/files/5.0.0/CVS/Repository
@@ -0,0 +1 @@
+gentoo-x86/dev-lang/php/files/5.0.0
diff --git a/dev-lang/php/files/5.0.0/CVS/Root b/dev-lang/php/files/5.0.0/CVS/Root
new file mode 100644
index 0000000..854a2c8
--- /dev/null
+++ b/dev-lang/php/files/5.0.0/CVS/Root
@@ -0,0 +1 @@
+:pserver:anonymous@anoncvs.gentoo.org:/var/cvsroot
diff --git a/dev-lang/php/files/5.0.0/CVS/Tag b/dev-lang/php/files/5.0.0/CVS/Tag
new file mode 100644
index 0000000..5062263
--- /dev/null
+++ b/dev-lang/php/files/5.0.0/CVS/Tag
@@ -0,0 +1 @@
+N1.1
diff --git a/dev-lang/php/files/5.0.0/php5-hphp-acinclude.patch b/dev-lang/php/files/5.0.0/php5-hphp-acinclude.patch
new file mode 100644
index 0000000..c5f1e71
--- /dev/null
+++ b/dev-lang/php/files/5.0.0/php5-hphp-acinclude.patch
@@ -0,0 +1,19 @@
+--- acinclude.m4.orig 2005-09-08 13:27:42.000000000 +0200
++++ acinclude.m4 2005-09-08 13:28:28.000000000 +0200
+@@ -779,12 +779,12 @@
+ dnl
+ AC_DEFUN([PHP_BUILD_PROGRAM],[
+ OVERALL_TARGET=[]ifelse($1,,php,$1)
+- php_c_pre='$(CC)'
++ php_c_pre='$(LIBTOOL) --mode=compile $(CC)'
+ php_c_meta='$(COMMON_FLAGS) $(CFLAGS_CLEAN) $(EXTRA_CFLAGS)'
+- php_c_post=' && echo > $[@]'
+- php_cxx_pre='$(CXX)'
++ php_c_post=
++ php_cxx_pre='$(LIBTOOL) --mode=compile $(CXX)'
+ php_cxx_meta='$(COMMON_FLAGS) $(CXXFLAGS_CLEAN) $(EXTRA_CXXFLAGS)'
+- php_cxx_post=' && echo > $[@]'
++ php_cxx_post=
+ php_lo=o
+
+ case $with_pic in
diff --git a/dev-lang/php/files/5.0.0/php5-imap-symlink.diff b/dev-lang/php/files/5.0.0/php5-imap-symlink.diff
new file mode 100644
index 0000000..99cfc9b
--- /dev/null
+++ b/dev-lang/php/files/5.0.0/php5-imap-symlink.diff
@@ -0,0 +1,15 @@
+--- ext/imap/config.m4 2005-09-04 02:49:45.000000000 +0200
++++ ext/imap/config.m4 2005-09-04 02:50:00.000000000 +0200
+@@ -146,12 +146,6 @@
+ AC_MSG_ERROR(Cannot find rfc822.h. Please check your c-client installation.)
+ fi
+
+- if test -r "$IMAP_DIR/c-client/c-client.a"; then
+- ln -s "$IMAP_DIR/c-client/c-client.a" "$IMAP_DIR/c-client/libc-client.a" >/dev/null 2>&1
+- elif test -r "$IMAP_DIR/lib/c-client.a"; then
+- ln -s "$IMAP_DIR/lib/c-client.a" "$IMAP_DIR/lib/libc-client.a" >/dev/null 2>&1
+- fi
+-
+ for lib in c-client4 c-client imap; do
+ IMAP_LIB=$lib
+ IMAP_LIB_CHK(lib)
diff --git a/dev-lang/php/files/5.0.0/php5-iodbc-config.diff b/dev-lang/php/files/5.0.0/php5-iodbc-config.diff
new file mode 100644
index 0000000..1e7a7c5
--- /dev/null
+++ b/dev-lang/php/files/5.0.0/php5-iodbc-config.diff
@@ -0,0 +1,14 @@
+--- ext/odbc/config.m4 2005-08-31 01:16:38.000000000 +0200
++++ ext/odbc/config.m4 2005-08-31 01:17:24.000000000 +0200
+@@ -408,9 +408,9 @@
+ fi
+ if test "$withval" != "no"; then
+ PHP_ADD_LIBRARY_WITH_PATH(iodbc, $withval/lib)
+- PHP_ADD_INCLUDE($withval/include, 1)
++ PHP_ADD_INCLUDE($withval/include/iodbc, 1)
+ ODBC_TYPE=iodbc
+- ODBC_INCLUDE=-I$withval/include
++ ODBC_INCLUDE=-I$withval/include/iodbc
+ ODBC_LFLAGS=-L$withval/lib
+ ODBC_LIBS=-liodbc
+ AC_DEFINE(HAVE_IODBC,1,[ ])
diff --git a/dev-lang/php/files/5.0.0/php5-libtool-1.5.patch b/dev-lang/php/files/5.0.0/php5-libtool-1.5.patch
new file mode 100644
index 0000000..7404992
--- /dev/null
+++ b/dev-lang/php/files/5.0.0/php5-libtool-1.5.patch
@@ -0,0 +1,19 @@
+--- acinclude.m4 2005-09-08 13:27:42.000000000 +0200
++++ acinclude.m4 2005-09-08 13:28:28.000000000 +0200
+@@ -779,12 +779,12 @@
+ dnl
+ AC_DEFUN([PHP_BUILD_PROGRAM],[
+ OVERALL_TARGET=[]ifelse($1,,php,$1)
+- php_c_pre='$(CC)'
++ php_c_pre='$(LIBTOOL) --mode=compile $(CC)'
+ php_c_meta='$(COMMON_FLAGS) $(CFLAGS_CLEAN) $(EXTRA_CFLAGS)'
+- php_c_post=' && echo > $[@]'
+- php_cxx_pre='$(CXX)'
++ php_c_post=
++ php_cxx_pre='$(LIBTOOL) --mode=compile $(CXX)'
+ php_cxx_meta='$(COMMON_FLAGS) $(CXXFLAGS_CLEAN) $(EXTRA_CXXFLAGS)'
+- php_cxx_post=' && echo > $[@]'
++ php_cxx_post=
+ php_lo=o
+
+ case $with_pic in
diff --git a/dev-lang/php/files/5.0.0/php5.0.4-pcre-security.patch b/dev-lang/php/files/5.0.0/php5.0.4-pcre-security.patch
new file mode 100644
index 0000000..548732d
--- /dev/null
+++ b/dev-lang/php/files/5.0.0/php5.0.4-pcre-security.patch
@@ -0,0 +1,38 @@
+--- configure.in 2005-09-17 21:42:36.000000000 +0200
++++ configure.in 2005-09-17 21:42:51.000000000 +0200
+@@ -41,7 +41,7 @@
+ MAJOR_VERSION=5
+ MINOR_VERSION=0
+ RELEASE_VERSION=4
+-EXTRA_VERSION=""
++EXTRA_VERSION="-gentoo-r1"
+ VERSION="$MAJOR_VERSION.$MINOR_VERSION.$RELEASE_VERSION$EXTRA_VERSION"
+
+ dnl Define where extension directories are located in the configure context
+--- ext/pcre/config.m4 2003/06/28 04:30:51 1.32
++++ ext/pcre/config.m4 2005/08/22 16:55:56 1.32.2.2
+@@ -1,5 +1,5 @@
+ dnl
+-dnl $Id: php5.0.4-pcre-security.patch,v 1.1 2005/09/18 13:21:54 hollow Exp $
++dnl $Id: php5.0.4-pcre-security.patch,v 1.1 2005/09/18 13:21:54 hollow Exp $
+ dnl
+
+ dnl By default we'll compile and link against the bundled PCRE library
+@@ -13,7 +13,7 @@ PHP_ARG_WITH(pcre-regex,for PCRE support
+
+ if test "$PHP_PCRE_REGEX" != "no"; then
+ if test "$PHP_PCRE_REGEX" = "yes"; then
+- PHP_NEW_EXTENSION(pcre, pcrelib/maketables.c pcrelib/get.c pcrelib/study.c pcrelib/pcre.c php_pcre.c, $ext_shared,,-DSUPPORT_UTF8 -DLINK_SIZE=2 -DPOSIX_MALLOC_THRESHOLD=10 -I@ext_srcdir@/pcrelib)
++ PHP_NEW_EXTENSION(pcre, pcrelib/pcre_chartables.c pcrelib/pcre_compile.c pcrelib/pcre_config.c pcrelib/pcre_dfa_exec.c pcrelib/pcre_exec.c pcrelib/pcre_fullinfo.c pcrelib/pcre_get.c pcrelib/pcre_globals.c pcrelib/pcre_info.c pcrelib/pcre_maketables.c pcrelib/pcre_ord2utf8.c pcrelib/pcre_printint.c pcrelib/pcre_refcount.c pcrelib/pcre_study.c pcrelib/pcre_tables.c pcrelib/pcre_try_flipped.c pcrelib/pcre_ucp_findchar.c pcrelib/pcre_valid_utf8.c pcrelib/pcre_version.c pcrelib/pcre_xclass.c php_pcre.c, $ext_shared,,-DEXPORT= -DNEWLINE=10 -DSUPPORT_UTF8 -DSUPPORT_UCP -DLINK_SIZE=2 -DPOSIX_MALLOC_THRESHOLD=10 -DMATCH_LIMIT=10000000 -I@ext_srcdir@/pcrelib)
+ PHP_ADD_BUILD_DIR($ext_builddir/pcrelib)
+ AC_DEFINE(HAVE_BUNDLED_PCRE, 1, [ ])
+ else
+@@ -50,7 +50,7 @@ if test "$PHP_PCRE_REGEX" != "no"; then
+
+ AC_DEFINE(HAVE_PCRE, 1, [ ])
+ PHP_ADD_INCLUDE($PCRE_INCDIR)
+- PHP_NEW_EXTENSION(pcre, php_pcre.c, $ext_shared,,-DSUPPORT_UTF8 -DLINK_SIZE=2 -DPOSIX_MALLOC_THRESHOLD=10)
++ PHP_NEW_EXTENSION(pcre, php_pcre.c, $ext_shared,,-DEXPORT= -DNEWLINE=10 -DSUPPORT_UTF8 -DSUPPORT_UCP -DLINK_SIZE=2 -DPOSIX_MALLOC_THRESHOLD=10 -DMATCH_LIMIT=10000000)
+ fi
+ PHP_SUBST(PCRE_SHARED_LIBADD)
+ fi
diff --git a/dev-lang/php/files/5.0.0/php5.0.4-xmlrcp-ccode.diff b/dev-lang/php/files/5.0.0/php5.0.4-xmlrcp-ccode.diff
new file mode 100644
index 0000000..15e5950
--- /dev/null
+++ b/dev-lang/php/files/5.0.0/php5.0.4-xmlrcp-ccode.diff
@@ -0,0 +1,23 @@
+--- ext/xmlrpc/libxmlrpc/xml_element.c 2004-06-01 22:16:06.000000000 +0200
++++ ext/xmlrpc/libxmlrpc/xml_element.c 2005-04-22 13:54:17.000000000 +0200
+@@ -113,7 +116,7 @@
+ #include "expat.h"
+ #include "encodings.h"
+
+-#define my_free(thing) if(thing) {free(thing); thing = 0;}
++#define my_free(thing) if(thing) {free(thing); thing = NULL;}
+
+ #define XML_DECL_START "<?xml"
+ #define XML_DECL_START_LEN sizeof(XML_DECL_START) - 1
+@@ -189,7 +192,10 @@
+
+ Q_Destroy(&root->children);
+ Q_Destroy(&root->attrs);
+- my_free((char*)root->name);
++ if(root->name) {
++ free((char *)root->name);
++ root->name = NULL;
++ }
+ simplestring_free(&root->text);
+ my_free(root);
+ }
diff --git a/dev-lang/php/files/5.0.0/php5.0.5-obj-serialize.patch b/dev-lang/php/files/5.0.0/php5.0.5-obj-serialize.patch
new file mode 100644
index 0000000..ed1ad2a
--- /dev/null
+++ b/dev-lang/php/files/5.0.0/php5.0.5-obj-serialize.patch
@@ -0,0 +1,42 @@
+--- ext/standard/incomplete_class.c 2004-11-25 20:28:37.000000000 +0000
++++ ext/standard/incomplete_class.c 2005-09-09 13:00:39.000000000 +0100
+@@ -122,7 +122,7 @@
+
+ /* {{{ php_lookup_class_name
+ */
+-char *php_lookup_class_name(zval *object, size_t *nlen)
++char *php_lookup_class_name(zval *object, zend_uint *nlen)
+ {
+ zval **val;
+ char *retval = NULL;
+@@ -144,7 +144,7 @@
+
+ /* {{{ php_store_class_name
+ */
+-void php_store_class_name(zval *object, const char *name, size_t len)
++void php_store_class_name(zval *object, const char *name, zend_uint len)
+ {
+ zval *val;
+ TSRMLS_FETCH();
+--- ./ext/standard/php_incomplete_class.h.bug34435 2005-06-29 10:29:08.000000000 +0100
++++ ./ext/standard/php_incomplete_class.h 2005-09-09 13:00:31.000000000 +0100
+@@ -42,7 +42,7 @@
+
+ #define PHP_CLASS_ATTRIBUTES \
+ char *class_name; \
+- size_t name_len; \
++ zend_uint name_len; \
+ zend_bool free_class_name = 0; \
+ zend_bool incomplete_class = 0
+
+@@ -55,8 +55,8 @@
+
+ zend_class_entry *php_create_incomplete_class(TSRMLS_D);
+
+-char *php_lookup_class_name(zval *object, size_t *nlen);
+-void php_store_class_name(zval *object, const char *name, size_t len);
++char *php_lookup_class_name(zval *object, zend_uint *nlen);
++void php_store_class_name(zval *object, const char *name, zend_uint len);
+
+ #ifdef __cplusplus
+ };