aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Martins <leonardo@venidera.com>2012-04-24 14:22:35 -0300
committerLeonardo Martins <leonardo@venidera.com>2012-04-24 14:22:35 -0300
commit8ab30466aad5f93697d916fcdaa029a13708c7ae (patch)
treedb9405b8e218ef0fe3139a9357dd42d38d93ec58 /dev-db/neo4j-community/neo4j-community-1.7.ebuild
parentAdded patches for Gentoo-style configuration path (diff)
downloadvenidera-8ab30466aad5f93697d916fcdaa029a13708c7ae.tar.gz
venidera-8ab30466aad5f93697d916fcdaa029a13708c7ae.tar.bz2
venidera-8ab30466aad5f93697d916fcdaa029a13708c7ae.zip
Renamed dev-db/neo4j-community to dev-db/neo4j
Diffstat (limited to 'dev-db/neo4j-community/neo4j-community-1.7.ebuild')
-rw-r--r--dev-db/neo4j-community/neo4j-community-1.7.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/dev-db/neo4j-community/neo4j-community-1.7.ebuild b/dev-db/neo4j-community/neo4j-community-1.7.ebuild
deleted file mode 100644
index 74392c8..0000000
--- a/dev-db/neo4j-community/neo4j-community-1.7.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-inherit eutils
-
-DESCRIPTION="Neo4j is a high-performance, NOSQL graph database with all the features of a mature and robust database."
-HOMEPAGE="http://neo4j.org/"
-SRC_URI="http://dist.neo4j.org/${PN}-${PV}-unix.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="!dev-db/neo4j-advanced
- !dev-db/neo4j-enterprise
- >=virtual/jre-1.6
- sys-process/lsof"
-
-src_unpack() {
- unpack ${A}
-}
-
-src_configure() {
- :;
-}
-
-src_compile() {
- :;
-}
-
-src_install() {
- exeinto /opt/neo4j/bin
- doexe "${S}"/bin/neo4j || die
- doexe "${S}"/bin/neo4j-shell || die
- doexe "${S}"/bin/utils || die
-
- # system requirements
- insinto /opt/neo4j/system/lib
- doins "${S}"/system/lib/*.jar || die
-
- # components directory
- insinto /opt/neo4j/lib
- doins "${S}"/lib/*.jar || die
-
- # plugins directory
- dodir /opt/neo4j/plugins
-
- # config files
- insinto /etc/neo4j
- doins "${S}"/conf/neo4j-wrapper.conf
- doins "${S}"/conf/neo4j.properties
- doins "${S}"/conf/neo4j-server.properties
- doins "${S}"/conf/logging.properties
-
- # documentation
- dodoc "${S}"/LICENSE.txt
- dodoc "${S}"/LICENSES.txt
- dodoc "${S}"/doc/neo4j.txt || die
- dodoc "${S}"/doc/neo4j-shell.txt || die
- dodoc "${S}"/doc/guide-post.html || die
- dodoc -r "${S}"/doc/java || die
- dodoc -r "${S}"/doc/manual || die
-
- # init script
- newinitd "${FILESDIR}"/neo4j.init neo4j || die
-
- # create symlinks
- dosym /opt/neo4j/bin/neo4j /opt/bin/neo4j || die
- dosym /opt/neo4j/bin/neo4j-shell /opt/bin/neo4j-shell || die
-}