aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Martins <leonardo@venidera.com>2012-04-23 14:14:56 -0300
committerLeonardo Martins <leonardo@venidera.com>2012-04-23 14:14:56 -0300
commit9567e37d4882c8bcb1a6471b66efcadd4c547a39 (patch)
treee7ae42f338c1e4558d7fe4ba9f7d98350ba135b7 /dev-db/neo4j-community/neo4j-community-1.7.ebuild
parentRolling releases are to be implemented (diff)
downloadvenidera-9567e37d4882c8bcb1a6471b66efcadd4c547a39.tar.gz
venidera-9567e37d4882c8bcb1a6471b66efcadd4c547a39.tar.bz2
venidera-9567e37d4882c8bcb1a6471b66efcadd4c547a39.zip
Added Neo4j 1.7 Community Edition graph database
Diffstat (limited to 'dev-db/neo4j-community/neo4j-community-1.7.ebuild')
-rw-r--r--dev-db/neo4j-community/neo4j-community-1.7.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/neo4j-community/neo4j-community-1.7.ebuild b/dev-db/neo4j-community/neo4j-community-1.7.ebuild
new file mode 100644
index 0000000..bc03c42
--- /dev/null
+++ b/dev-db/neo4j-community/neo4j-community-1.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Neo4j is a high-performance, NOSQL graph database with all the features of a mature and robust database."
+HOMEPAGE="http://neo4j.org/"
+SRC_URI="http://dist.neo4j.org/${PN}-${PV}-unix.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="!dev-db/neo4j-advanced
+ !dev-db/neo4j-enterprise
+ >=virtual/jre-1.6
+ sys-process/lsof"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_configure() {
+ :;
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ insinto /opt/neo4j
+ dodir /opt/bin
+
+ doins -r * || die
+ fperms 0700 /opt/neo4j/bin/neo4j
+ fperms 0700 /opt/neo4j/bin/neo4j-shell
+ fperms 0700 /opt/neo4j/bin/utils
+
+ # create symlinks
+ dosym /opt/neo4j/bin/neo4j /opt/bin/neo4j
+ dosym /opt/neo4j/bin/neo4j-shell /opt/bin/neo4j-shell
+}