summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIskren Slavov <iskren.s@gmail.com>2010-12-07 16:00:31 +0200
committerIskren Slavov <iskren.s@gmail.com>2010-12-07 16:00:31 +0200
commit071c8083ce06294e03b5a7e704e32c0c7389ac9a (patch)
tree4189662e5b9e6209b4dbb0e3d655ddbf7e35ce33 /sys-apps
parentgo-oo-bin fixes. fluback moved to /opt (diff)
downloadwish-071c8083ce06294e03b5a7e704e32c0c7389ac9a.tar.gz
wish-071c8083ce06294e03b5a7e704e32c0c7389ac9a.tar.bz2
wish-071c8083ce06294e03b5a7e704e32c0c7389ac9a.zip
Added gambas, system-config-users (and it's dependencies)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/usermode/Manifest2
-rw-r--r--sys-apps/usermode/usermode-1.106.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/sys-apps/usermode/Manifest b/sys-apps/usermode/Manifest
new file mode 100644
index 0000000..5d2ef76
--- /dev/null
+++ b/sys-apps/usermode/Manifest
@@ -0,0 +1,2 @@
+DIST usermode-1.106.tar.xz 282976 RMD160 14142e02d22c7012a5ed4dc99d647202639cfade SHA1 0c7b34fa7a79d705ea3373c81bea2cea599e4993 SHA256 fb3632883106e4c0ba6386fbe071dd14d06a13c2ab5d0835e3746906c173c0aa
+EBUILD usermode-1.106.ebuild 1926 RMD160 e6b88327b3d9297ea52fc99e9bb4c9f7c5b5122c SHA1 6157e10ab2ce5c3c28d0f99c07920ed9b3ed4c67 SHA256 01f48000046486afbd76cabb0b72f165a27af4913dc547182f9ade60983bbfc2
diff --git a/sys-apps/usermode/usermode-1.106.ebuild b/sys-apps/usermode/usermode-1.106.ebuild
new file mode 100644
index 0000000..0ca8b82
--- /dev/null
+++ b/sys-apps/usermode/usermode-1.106.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit base flag-o-matic autotools eutils
+
+EAPI="3"
+
+DESCRIPTION="Tools for certain user account management tasks"
+HOMEPAGE="https://fedorahosted.org/usermode/"
+SRC_URI="https://fedorahosted.org/releases/u/s/${PN}/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug selinux"
+RDEPEND="=dev-libs/glib-2*
+ =x11-libs/gtk+-2*
+ =gnome-base/libglade-2*
+ sys-apps/attr
+ x11-libs/libSM
+ dev-util/desktop-file-utils
+ sys-libs/system-config-base
+ >=sys-libs/pam-0.75
+ sys-apps/shadow
+ dev-perl/XML-Parser
+ sys-libs/libuser"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+pkg_setup() {
+ if ! built_with_use sys-apps/shadow pam; then
+ eerror "${CATEGORY}/${PN} depends on the chfn and passwd PAM service"
+ eerror "configuration files installed by sys-apps/shadow with PAM"
+ eerror "enabled."
+ eerror "Please re-install sys-apps/shadow with the pam USE flag"
+ eerror "enabled."
+ die "sys-apps/shadow was built without PAM support."
+ fi
+}
+
+src_prepare() {
+ cd "${S}"
+
+ # Change vendor prefix of desktop file from redhat to gentoo
+ sed -i -e "s:^\(VENDOR=\).*:\1gentoo:g" Makefile.am
+
+ # Invalid categories in desktop-file-utils-0.11 (#153395)
+ sed -i \
+ -e "/AdvancedSettings/d" \
+ -e "/Application/d" \
+ -e "/X-Red-Hat-Base/d" \
+ Makefile.am
+
+ # Invalid naming of icons
+ sed -i \
+ -e "s:\.png::g" \
+ *.desktop.in
+
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,now
+
+ econf \
+ $(use_with selinux) \
+ $(use_enable debug) \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # This needs to be suid, it's the main interface with suid-requiring stuff
+ fperms 4711 /usr/sbin/userhelper
+
+ # Don't install a shutdown executable, it will be preferred over /sbin/
+ rm "${D}"/usr/bin/shutdown
+}
+