summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Phillips <write2david@gmail.com>2012-05-16 02:04:16 -0500
committerDavid Phillips <write2david@gmail.com>2012-05-16 02:04:16 -0500
commita38678cd3320be180e04aad58fdd9431e3dd1f82 (patch)
tree1c990b8e786e279023a219fce13ba19655aeb5d1 /app-portage
parentNew dependencies and comments for cairo-dock* (diff)
downloadwrite2David-a38678cd3320be180e04aad58fdd9431e3dd1f82.tar.gz
write2David-a38678cd3320be180e04aad58fdd9431e3dd1f82.tar.bz2
write2David-a38678cd3320be180e04aad58fdd9431e3dd1f82.zip
add bemerge-0.50
Diffstat (limited to 'app-portage')
-rwxr-xr-xapp-portage/bemerge/bemerge-0.50.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/app-portage/bemerge/bemerge-0.50.ebuild b/app-portage/bemerge/bemerge-0.50.ebuild
new file mode 100755
index 0000000..d28a3b0
--- /dev/null
+++ b/app-portage/bemerge/bemerge-0.50.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+
+# Helpful information for me:
+# http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=1
+# http://devmanual.gentoo.org/ebuild-writing/index.html
+# http://linuxreviews.org/man/ebuild/
+
+# Contains the list of variables & functions available for using git in ebuilds:
+# http://gentoo-overlays.zugaina.org/kde/portage/eclass/git.eclass
+
+
+EAPI="3"
+
+inherit eutils git
+
+DESCRIPTION="a wrapper script for emerge to make it easier"
+HOMEPAGE="https://github.com/write2david/bemerge"
+SRC_URI=""
+
+
+EGIT_REPO_URI="git://github.com/write2david/bemerge.git"
+EGIT_BRANCH="master"
+
+# The commit of version 0.50
+EGIT_COMMIT="92e184d"
+
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="mirror test"
+
+
+RDEPEND="
+ sys-process/time
+ app-admin/localepurge
+ sys-kernel/module-rebuild
+ sys-process/lsof
+ app-admin/checkrestart
+ app-portage/portage-utils
+ "
+
+
+src_unpack() {
+ git_src_unpack
+}
+
+
+src_install() {
+
+ # Dictate where the executable will be installed to
+ exeinto /usr/bin
+
+ # Now put the executable in said location
+ doexe bemerge
+ doexe temerge
+
+
+pkg_postinst() {
+ einfo
+ einfo "You may now use 'bemerge' instead of 'emerge'"
+ einfo "Or, to build a package using RAM instead of your hard drive for
+ storage"
+ einfo " you can run 'temerge' instead of 'bemerge'."
+ einfo " See http://en.gentoo-wiki.com/wiki/Portage_TMPDIR_on_tmpfs for
+ more info."
+ }
+
+}