summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Phillips <write2david@gmail.com>2012-10-31 23:15:37 -0500
committerDavid Phillips <write2david@gmail.com>2012-10-31 23:15:37 -0500
commitf18cd15c06bf815dd04e73c5c744f23333fd47ad (patch)
tree6043752dbeb1e26f99980b52c51c3443688c0dff /x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
parentOops, forgot to update the Manifests (diff)
downloadwrite2David-f18cd15c06bf815dd04e73c5c744f23333fd47ad.tar.gz
write2David-f18cd15c06bf815dd04e73c5c744f23333fd47ad.tar.bz2
write2David-f18cd15c06bf815dd04e73c5c744f23333fd47ad.zip
Fixing per upstream bug report...
...https://bugs.launchpad.net/cairo-dock-core/+bug/1073734
Diffstat (limited to 'x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild')
-rw-r--r--x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
index 628aaeb..cc5cbac 100644
--- a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
+++ b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
@@ -15,6 +15,7 @@ inherit cmake-utils bzr
DESCRIPTION="Official plugins for cairo-dock"
HOMEPAGE="https://launchpad.net/cairo-dock-plug-ins/"
+# Next line is not needed because the BZR repository is specified further above
SRC_URI=""
LICENSE="GPL-3"
@@ -56,9 +57,11 @@ pkg_setup()
{
ewarn ""
ewarn ""
- ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn "You are installing from a LIVE EBUILD, NOT AN OFFICIAL RELEASE."
ewarn " Thus, it may FAIL to build properly."
- ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn ""
+ ewarn "This ebuild is not supported by a Gentoo developer."
+ ewarn " So, please do NOT report bugs to Gentoo's bugzilla."
ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""
@@ -89,13 +92,6 @@ src_configure() {
# However, adding this to "configure" not "compile" because the error show
# up during configure stage.
- # Weird, cairo-dock installs files are under /usr/usr not /usr
-
- export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}:/usr/usr/lib/pkgconfig:/usr/usr/lib6464/pkgconfig"
-
- # Check the PKG_CONFIG_PATH value to make sure we're good...
- echo "The pkg_config variable is: ${PKG_CONFIG_PATH}"
-
# Next line added because of the same issues/solutions reported on...
# ... # https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981
@@ -104,18 +100,22 @@ src_configure() {
# http://code.google.com/p/rion-overlay/source/browse/x11-misc/cairo-dock-plugins/cairo-dock-plugins-2.3.9999.ebuild?spec=svn71d4acbbb8c297b818ff886fb5dd434a6f54c377&r=71d4acbbb8c297b818ff886fb5dd434a6f54c377
# Some more info... http://www.cmake.org/Wiki/CMake_Useful_Variables
- mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr"
+
+
+ # Adding the "-DLIB_SUFFIX" flag b/c https://bugs.launchpad.net/cairo-dock-core/+bug/1073734
+
+ mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr -DLIB_SUFFIX=\"\""
cmake-utils_src_configure
}
pkg_postinst() {
ewarn ""
ewarn ""
- ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn "You have installed from a LIVE EBUILD, NOT AN OFFICIAL RELEASE."
ewarn " Thus, it may FAIL to run properly."
ewarn ""
- ewarn "This ebuild is not supported by an Gentoo developer."
- ewarn " So please do NOT report bugs to Gentoo's bugzilla."
+ ewarn "This ebuild is not supported by a Gentoo developer."
+ ewarn " So, please do NOT report bugs to Gentoo's bugzilla."
ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""