summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/cairo-dock-plugins/Manifest2
-rw-r--r--x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild29
2 files changed, 14 insertions, 17 deletions
diff --git a/x11-plugins/cairo-dock-plugins/Manifest b/x11-plugins/cairo-dock-plugins/Manifest
index 096de2c..9ec4790 100644
--- a/x11-plugins/cairo-dock-plugins/Manifest
+++ b/x11-plugins/cairo-dock-plugins/Manifest
@@ -1,4 +1,4 @@
-EBUILD cairo-dock-plugins-9999-r1.ebuild 3222 RMD160 eadf489f6f37c3c387a957b0f296ae9964d3d44a SHA1 cc3a470f274991415b79c22f36cd91c9dbbc4e77 SHA256 37edceba32fca56a7d5c204d7bfa9f8c81c11a36e86f55ea306a879de577c3c2
+EBUILD cairo-dock-plugins-9999-r1.ebuild 3409 RMD160 0de4277f53846e7be6a6993cfeea0fd1bf77b296 SHA1 9ea48d2891b172573075241f0b4a1bb559d3c5e7 SHA256 677cae37fc4dfd6e9dc16f412858f096f282d31e59140863a1c0a6976b223cba
EBUILD cairo-dock-plugins-9999.ebuild 2916 RMD160 261557b98a558304fb6a04c62fe124b6f2c9ccca SHA1 652f06bd27049676f0b56508c2907105b13c2f3b SHA256 fa91a8cb095df1a25a4362065ad1aea0367656da1e439c1f0e45da35bdf0b3d4
MISC ChangeLog 240 RMD160 55af20059609afd5f2f7c6587a398a8771ad3b97 SHA1 954131dc27940452045dd947d865332f92420cbe SHA256 ffd103359939888e5c0463fda3245d4e54b55fdcc16782e5e83f14fbaaa31efd
MISC metadata.xml 276 RMD160 0c0c308f1457fd6b3524628543f0452d1dc39197 SHA1 e296372ecbbb13ad02430b5d323ea54c7fc5f086 SHA256 cc9796aef23ea695fd2cc82f8c763e3463f4ddcc335f716740ef0d568f4ca6e9
diff --git a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild
index 4309297..e1f75cb 100644
--- a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild
+++ b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -11,7 +11,6 @@ EBZR_REPO_URI="lp:cairo-dock-plug-ins"
# Or comment it out to choose the latest ("live") revision.
#EBZR_REVISION="2242"
-
inherit cmake-utils bzr
DESCRIPTION="Official plugins for cairo-dock"
@@ -22,13 +21,11 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-
# The next line has been stripped down somewhat from a longer version
# used in the ebuilds of other overlays. For more info, see:
# https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981/comments/8
IUSE="alsa exif gmenu terminal vala webkit xfce xgamma xklavier"
-
# Dependencies are listed here:
# http://glx-dock.org/ww_page.php?p=From%20BZR&lang=en
@@ -48,14 +45,12 @@ RDEPEND="
vala? ( dev-lang/vala:0.12 )
"
-
DEPEND="${RDEPEND}
dev-util/intltool
sys-devel/gettext
dev-util/pkgconfig
"
-
pkg_setup()
{
ewarn ""
@@ -68,18 +63,15 @@ pkg_setup()
ewarn ""
}
-
src_prepare() {
bzr_src_prepare
}
-
# ==== The following lines are from someone else's ebuild, with my notes...
# Can't find out what the following line does (no Gentoo documentation on it?) and it seems to find the makefile and compile fine without it, so commenting it out.
#MAKE_IN_SOURCE_BUILD=true
-
# Actually, it looks like it is supposed to be CMAKE_IN_SOURCE_BUILD
# http://devmanual.gentoo.org/eclass-reference/cmake-utils.eclass/index.html
# But still not needed, so it is still commented out.
@@ -87,23 +79,28 @@ src_prepare() {
# ====== END =====
-
src_configure() {
- # Next line added because of the same issues/solution as reported on...
- # ... http://glx-dock.org/bg_topic.php?t=5733
- export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig
-
- # Next line added because of the same issues/solutions reported on...
+ # Next line added because of the same issues/solutions reported on...
# ... # https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981
#
# With a solution inspired on...
# http://code.google.com/p/rion-overlay/source/browse/x11-misc/cairo-dock-plugins/cairo-dock-plugins-2.3.9999.ebuild?spec=svn71d4acbbb8c297b818ff886fb5dd434a6f54c377&r=71d4acbbb8c297b818ff886fb5dd434a6f54c377
- mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr"
+ mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr"
cmake-utils_src_configure
}
+src_compile() {
+ # Next line added because of the same issues/solution as reported on...
+ # ... http://glx-dock.org/bg_topic.php?t=5733
+
+ # Where to put this variable declaration was inspired from...
+ # http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/x11-libs/cairo/cairo-0.1.18.ebuild?hideattic=0&view=markup
+
+ PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig
+ emake || die
+}
pkg_postinst() {
ewarn ""