summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/bemerge/bemerge-0.47.ebuild')
-rwxr-xr-xapp-portage/bemerge/bemerge-0.47.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/app-portage/bemerge/bemerge-0.47.ebuild b/app-portage/bemerge/bemerge-0.47.ebuild
deleted file mode 100755
index 1888de9..0000000
--- a/app-portage/bemerge/bemerge-0.47.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-
-# Helpful information for me:
-# http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=1
-# http://devmanual.gentoo.org/ebuild-writing/index.html
-# http://linuxreviews.org/man/ebuild/
-
-# Contains the list of variables & functions available for using git in ebuilds:
-# http://gentoo-overlays.zugaina.org/kde/portage/eclass/git.eclass
-
-
-EAPI="3"
-
-inherit eutils git
-
-DESCRIPTION="a wrapper script for emerge to make it better"
-HOMEPAGE="https://github.com/write2david/bemerge"
-SRC_URI=""
-
-
-EGIT_REPO_URI="git://github.com/write2david/bemerge.git"
-EGIT_BRANCH="master"
-
-# The commit of version 0.47
-EGIT_COMMIT="fdf8084010"
-
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-RESTRICT="mirror test"
-
-
-RDEPEND="
- sys-process/time
- app-admin/localepurge
- sys-kernel/module-rebuild
- sys-process/lsof
- app-admin/checkrestart
- app-portage/portage-utils
- "
-
-
-src_unpack() {
- git_src_unpack
-}
-
-
-src_install() {
-
- # Dictate where the executable will be installed to
- exeinto /usr/bin
-
- # Now put the executable in said location
- doexe bemerge
- doexe temerge
-
-
-pkg_postinst() {
- einfo
- einfo "You may now use 'bemerge' instead of 'emerge'"
- einfo "Or, to build a package using RAM instead of your hard drive for
- storage"
- einfo " you can run 'temerge' instead of 'bemerge'."
- einfo " See http://en.gentoo-wiki.com/wiki/Portage_TMPDIR_on_tmpfs for
- more info."
- }
-
-}