summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/cairo-dock/cairo-dock-9999.ebuild')
-rw-r--r--x11-misc/cairo-dock/cairo-dock-9999.ebuild25
1 files changed, 22 insertions, 3 deletions
diff --git a/x11-misc/cairo-dock/cairo-dock-9999.ebuild b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
index 133f4a1..aa7de05 100644
--- a/x11-misc/cairo-dock/cairo-dock-9999.ebuild
+++ b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
@@ -25,7 +25,7 @@ KEYWORDS=""
IUSE="xcomposite"
-# Dependencies are listed here:
+# Installation instructions (from BZR source) and dependencies are listed here:
# http://glx-dock.org/ww_page.php?p=From%20BZR&lang=en
RDEPEND="
@@ -74,7 +74,26 @@ src_prepare() {
}
-MAKE_IN_SOURCE_BUILD=true
+# Not sure what the next line does. Can't find any documenation about it.
+# Maybe it does nothing? Help?!
+#MAKE_IN_SOURCE_BUILD=true
+
+src_configure() {
+
+ # Next line added because of the same issues/solutions reported on...
+ # ... # https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981
+ #
+ # With a solution inspired on...
+ # http://code.google.com/p/rion-overlay/source/browse/x11-misc/cairo-dock-plugins/cairo-dock-plugins-2.3.9999.ebuild?spec=svn71d4acbbb8c297b818ff886fb5dd434a6f54c377&r=71d4acbbb8c297b818ff886fb5dd434a6f54c377
+
+ # These CMAKE variables are listed on the BZR installation instructions
+ # (link above)
+
+ # Some more info...
+ # http://www.cmake.org/Wiki/CMake_Useful_Variables
+ mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr"
+ cmake-utils_src_configure
+}
pkg_postinst() {
@@ -86,4 +105,4 @@ pkg_postinst() {
ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""
-} \ No newline at end of file
+}