summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/cairo-dock/cairo-dock-9999.ebuild')
-rw-r--r--x11-misc/cairo-dock/cairo-dock-9999.ebuild42
1 files changed, 22 insertions, 20 deletions
diff --git a/x11-misc/cairo-dock/cairo-dock-9999.ebuild b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
index 2981cd4..dace87a 100644
--- a/x11-misc/cairo-dock/cairo-dock-9999.ebuild
+++ b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
@@ -17,6 +17,7 @@ EBZR_REPO_URI="lp:cairo-dock-core"
DESCRIPTION="Cairo-dock is a fast, responsive, Mac OS X-like dock."
HOMEPAGE="https://launchpad.net/cairo-dock-core/"
+# Next line is not needed because the BZR repository is specified further above
SRC_URI=""
LICENSE="GPL-2"
@@ -59,30 +60,27 @@ pkg_setup()
{
ewarn ""
ewarn ""
- ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn "You are installing from a LIVE EBUILD, NOT AN OFFICIAL RELEASE."
ewarn " Thus, it may FAIL to build properly."
ewarn ""
- ewarn "This ebuild is not supported by an Gentoo developer."
- ewarn " So please do NOT report bugs to Gentoo's bugzilla."
+ ewarn "This ebuild is not supported by a Gentoo developer."
+ ewarn " So, please do NOT report bugs to Gentoo's bugzilla."
ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""
- # Dealing with the weird behavior of cairo-dock installing
+ # We have to deal with the weird behavior of cairo-dock installing
# stuff under "/usr/usr/lib" for 32-bit systems.
- # Also, the weird reported behavior of cairo-dock installing
- # stuff under "/usr/usr/lib6464" for 64-bit system.
+ # ... installing stuff under "/usr/usr/lib6464" for 64-bit systems.
- # We are doing this so that files actually get placed into the normal directory
+ # So, we do the following so that files get installed into the normal directory...
mkdir /usr/usr
- ln -s /usr/lib /usr/usr/lib
- ln -s /usr/lib64 /usr/usr/lib6464/
+ ln -s /usr/lib /usr/usr/lib
+ ln -s /usr/lib64 /usr/usr/lib6464/
- # Note that the first 'ln' will fail if we're on a 64-bit system. That's
- # okay.
- # Note that the second 'ln' will fail if we're on a 32-bit system. THat's
- # okay.
+ # Note that the first 'ln' will fail if we're on a 64-bit system. That's okay.
+ # Note that the second 'ln' will fail if we're on a 32-bit system. That's okay.
}
@@ -107,12 +105,14 @@ src_configure() {
# With a solution inspired on...
# http://code.google.com/p/rion-overlay/source/browse/x11-misc/cairo-dock-plugins/cairo-dock-plugins-2.3.9999.ebuild?spec=svn71d4acbbb8c297b818ff886fb5dd434a6f54c377&r=71d4acbbb8c297b818ff886fb5dd434a6f54c377
- # These CMAKE variables are listed on the BZR installation instructions
- # (link above)
+ # These CMAKE variables are listed in the BZR installation instructions (link above)
+ # Some more info... http://www.cmake.org/Wiki/CMake_Useful_Variables
- # Some more info...
- # http://www.cmake.org/Wiki/CMake_Useful_Variables
- mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr"
+
+ # Adding the "-DLIB_SUFFIX" flag b/c https://bugs.launchpad.net/cairo-dock-core/+bug/1073734
+
+
+ mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr -DLIB_SUFFIX=\"\""
cmake-utils_src_configure
}
@@ -120,9 +120,11 @@ src_configure() {
pkg_postinst() {
ewarn ""
ewarn ""
- ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn "You have installed from a LIVE EBUILD, NOT AN OFFICIAL RELEASE."
ewarn " Thus, it may FAIL to run properly."
- ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn ""
+ ewarn "This ebuild is not supported by a Gentoo developer."
+ ewarn " So, please do NOT report bugs to Gentoo's bugzilla."
ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""