summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/cairo-dock/cairo-dock-9999.ebuild21
1 files changed, 18 insertions, 3 deletions
diff --git a/x11-misc/cairo-dock/cairo-dock-9999.ebuild b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
index aa7de05..1e9896a 100644
--- a/x11-misc/cairo-dock/cairo-dock-9999.ebuild
+++ b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
@@ -61,10 +61,23 @@ pkg_setup()
ewarn ""
ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
ewarn " Thus, it may FAIL to build properly."
- ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn ""
+ ewarn "This ebuild is not supported by an Gentoo developer."
+ ewarn " So please do NOT report bugs to Gentoo's bugzilla."
ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""
+
+ # Dealing with the weird behavior of cairo-dock installing
+ # stuff under "/usr/usr/lib" for 32-bit systems.
+ # Also, the weird reported behavior of cairo-dock installing
+ # stuff under "/usr/usr/lib6464" for 64-bit system.
+
+ # We are doing this so that files are actually placed into the normal directory
+
+ ln -s /usr/lib /usr/usr/lib
+ ln -s /usr/lib64 /usr/usr/lib6464/
+
}
@@ -74,10 +87,12 @@ src_prepare() {
}
-# Not sure what the next line does. Can't find any documenation about it.
-# Maybe it does nothing? Help?!
+# Not sure what the next line does. Can't find any documentation about it.
+# Maybe it does nothing? It came from someone else's old ebuild for
+# cairo-dock. Help?!
#MAKE_IN_SOURCE_BUILD=true
+
src_configure() {
# Next line added because of the same issues/solutions reported on...