summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild')
-rw-r--r--x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild38
1 files changed, 22 insertions, 16 deletions
diff --git a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild
index e3dd30a..7abbbbb 100644
--- a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild
+++ b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild
@@ -26,7 +26,7 @@ KEYWORDS=""
# https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981/comments/8
IUSE="alsa exif gmenu terminal vala webkit xfce xgamma xklavier"
-# Dependencies are listed here:
+# Installation instructions (from BZR source) and dependencies are listed here:
# http://glx-dock.org/ww_page.php?p=From%20BZR&lang=en
RDEPEND="
@@ -49,6 +49,7 @@ DEPEND="${RDEPEND}
dev-util/intltool
sys-devel/gettext
dev-util/pkgconfig
+ dev-libs/libdbusmenu:3[gtk]
"
pkg_setup()
@@ -80,29 +81,31 @@ src_prepare() {
src_configure() {
- # Next line added because of the same issues/solutions reported on...
- # ... # https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981
- #
- # With a solution inspired on...
- # http://code.google.com/p/rion-overlay/source/browse/x11-misc/cairo-dock-plugins/cairo-dock-plugins-2.3.9999.ebuild?spec=svn71d4acbbb8c297b818ff886fb5dd434a6f54c377&r=71d4acbbb8c297b818ff886fb5dd434a6f54c377
-
- mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr"
- cmake-utils_src_configure
-}
-
-src_compile() {
# Next line added because of the same issues/solution as reported on...
# ... http://glx-dock.org/bg_topic.php?t=5733
# Where to put this variable declaration was inspired from...
# http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/x11-libs/cairo/cairo-0.1.18.ebuild?hideattic=0&view=markup
+ # However, adding this to "configure" not "compile" because the error show
+ # up during configure stage.
- PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig
+ # Weird, cairo-dock installs files are under /usr/usr not /usr
- # May also need this?
- #pkg-config gldi --variable=pluginsdir
+ export PKG_CONFIG_PATH="${PKG_CONFIG_PATH:+${PKG_CONFIG_PATH}:}/usr/usr/lib/pkgconfig"
- emake || die
+ # Check the PKG_CONFIG_PATH value to make sure we're good...
+ echo "The pkg_config variable is: ${PKG_CONFIG_PATH}"
+
+
+ # Next line added because of the same issues/solutions reported on...
+ # ... # https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981
+ #
+ # With a solution inspired on...
+ # http://code.google.com/p/rion-overlay/source/browse/x11-misc/cairo-dock-plugins/cairo-dock-plugins-2.3.9999.ebuild?spec=svn71d4acbbb8c297b818ff886fb5dd434a6f54c377&r=71d4acbbb8c297b818ff886fb5dd434a6f54c377
+
+ # Some more info... http://www.cmake.org/Wiki/CMake_Useful_Variables
+ mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr"
+ cmake-utils_src_configure
}
pkg_postinst() {
@@ -114,4 +117,7 @@ pkg_postinst() {
ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""
+ # Dealing with the weird issue of cairo-dock installing under /usr/usr
+ # Without this next line, cairo-dock won't start
+ ln -s /usr/usr/lib/libgldi.so.3 /usr/lib/libgldi.so.3
}