summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Huber <huber@crans.org>2010-04-30 18:46:11 -0400
committerOlivier Huber <huber@crans.org>2010-04-30 18:46:11 -0400
commit3999e25ea279fb916b4b284c604aee74293edd45 (patch)
treed8fb7718c02ab29c50be51f64c448ac5bb677822
parentBug #317047 has been fixed (diff)
downloadxhub-3999e25ea279fb916b4b284c604aee74293edd45.tar.gz
xhub-3999e25ea279fb916b4b284c604aee74293edd45.tar.bz2
xhub-3999e25ea279fb916b4b284c604aee74293edd45.zip
Bump Joomla
This new realease contains only bug and security fixes
-rw-r--r--www-apps/joomla/Manifest3
-rw-r--r--www-apps/joomla/files/postinstall-en.txt25
-rw-r--r--www-apps/joomla/joomla-1.5.17.ebuild54
3 files changed, 82 insertions, 0 deletions
diff --git a/www-apps/joomla/Manifest b/www-apps/joomla/Manifest
new file mode 100644
index 0000000..6cb60fd
--- /dev/null
+++ b/www-apps/joomla/Manifest
@@ -0,0 +1,3 @@
+AUX postinstall-en.txt 754 RMD160 ebc0e7808af410d94fb6fa1b7296ecee1ffa15ec SHA1 bc1c99b4edaaee5d97826543f47c6efcf134df2d SHA256 36261f2301653a1c715a9edf43d0ad89fd0721e3a6c4e55ad4d4b7f1b5adf28c
+DIST Joomla_1.5.17-Stable-Full_Package.zip 6898964 RMD160 478578ee854107b98651baf0ac6e2c771081fa57 SHA1 7c550ca88667d4a1f155dd0310b5f01a7c6152ad SHA256 71bdcb834d96564002d3deb70e645f473f1adbb1af2f341c6b28ff97c490d3d7
+EBUILD joomla-1.5.17.ebuild 1522 RMD160 243c0c1a4029a91f866fd215e48f0d23dfb3c1db SHA1 4534897ded4c5fd6d7d4a58ae5f45edc6d26e8c8 SHA256 08ca5d27e8026bfec9ab161859412b1a56edac5e54846ec5f56a7d6f9d68df38
diff --git a/www-apps/joomla/files/postinstall-en.txt b/www-apps/joomla/files/postinstall-en.txt
new file mode 100644
index 0000000..86606ab
--- /dev/null
+++ b/www-apps/joomla/files/postinstall-en.txt
@@ -0,0 +1,25 @@
+You are almost done!
+
+ 0. Setup a database (e.g. MySQL: see
+ http://www.gentoo.org/doc/en/mysql-howto.xml)
+
+ 1. Login on http://${VHOST_HOSTNAME}/${VHOST_APPDIR}
+ and finish the installation.
+
+
+ 2. Move into the directory where you installed Joomla and remove
+ the "installation" folder:
+
+ # cd ${MY_INSTALLDIR}
+ # rm -rf installation
+
+ 3. You can now launch your browser and point it to your Joomla site e.g.
+
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR} -> Main Site
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/administrator -> Admin
+
+ You can log into the administration view using the username 'admin'
+ along with the password that was generated or you chose during the
+ web based installation.
+
+ Enjoy Joomla!
diff --git a/www-apps/joomla/joomla-1.5.17.ebuild b/www-apps/joomla/joomla-1.5.17.ebuild
new file mode 100644
index 0000000..0263483
--- /dev/null
+++ b/www-apps/joomla/joomla-1.5.17.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/joomla/joomla-1.5.15.ebuild,v 1.1 2009/12/25 00:37:12 fauli Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Joomla is a powerful Open Source Content Management System."
+HOMEPAGE="http://www.joomla.org/"
+SRC_URI="http://joomlacode.org/gf/download/frsrelease/12193/49780/Joomla_${PV}-Stable-Full_Package.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"
+
+DEPEND="${DEPEND}
+ app-arch/unzip"
+RDEPEND=""
+
+pkg_setup () {
+ webapp_pkg_setup
+ require_php_with_use mysql zlib xml
+}
+
+src_install () {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.php INSTALL.php
+
+ touch configuration.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local files="administrator/backups administrator/cache
+ administrator/components administrator/language administrator/language/en-GB
+ administrator/modules administrator/templates cache components images
+ images/banners images/stories language language/en-GB language/pdf_fonts
+ media modules plugins plugins/content plugins/editors plugins/editors-xtd
+ plugins/search plugins/system plugins/user plugins/xmlrpc tmp templates"
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${file}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/configuration.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}