summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-04-23 18:33:43 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-04-23 19:16:20 +0300
commit5ed57a03d08d1996b13c8c5391800d9119376969 (patch)
tree89e32e89891e9794a0aa268fbbf2ece09aad6ca7 /dev-python/rsa/rsa-4.0.ebuild
parentdev-python/pylru: Initial import (diff)
downloadalexxy-5ed57a03d08d1996b13c8c5391800d9119376969.tar.gz
alexxy-5ed57a03d08d1996b13c8c5391800d9119376969.tar.bz2
alexxy-5ed57a03d08d1996b13c8c5391800d9119376969.zip
dev-python/rsa: Version bump
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python/rsa/rsa-4.0.ebuild')
-rw-r--r--dev-python/rsa/rsa-4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/rsa/rsa-4.0.ebuild b/dev-python/rsa/rsa-4.0.ebuild
new file mode 100644
index 0000000..0fb7d5a
--- /dev/null
+++ b/dev-python/rsa/rsa-4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="https://stuvel.eu/rsa https://pypi.org/project/rsa/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
+ dev-python/traceback2[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6.10[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --verbose || die
+}