summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-09-27 11:21:05 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2012-09-27 11:21:05 +0400
commitba0d1f9e5b8f0f6fc92face3c69842b13032b570 (patch)
tree2f1f4e01fdd1509698880b7c90835c56a3f53d75 /net-misc/openvpn-mysql-auth
parentIt wants 1.11 automake (diff)
downloadalexxy-ba0d1f9e5b8f0f6fc92face3c69842b13032b570.tar.gz
alexxy-ba0d1f9e5b8f0f6fc92face3c69842b13032b570.tar.bz2
alexxy-ba0d1f9e5b8f0f6fc92face3c69842b13032b570.zip
add mysql auth
(Portage version: 2.2.0_alpha131/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/openvpn-mysql-auth')
-rw-r--r--net-misc/openvpn-mysql-auth/metadata.xml8
-rw-r--r--net-misc/openvpn-mysql-auth/openvpn-mysql-auth-9999.ebuild45
2 files changed, 53 insertions, 0 deletions
diff --git a/net-misc/openvpn-mysql-auth/metadata.xml b/net-misc/openvpn-mysql-auth/metadata.xml
new file mode 100644
index 0000000..247f458
--- /dev/null
+++ b/net-misc/openvpn-mysql-auth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/openvpn-mysql-auth/openvpn-mysql-auth-9999.ebuild b/net-misc/openvpn-mysql-auth/openvpn-mysql-auth-9999.ebuild
new file mode 100644
index 0000000..cb5c6cd
--- /dev/null
+++ b/net-misc/openvpn-mysql-auth/openvpn-mysql-auth-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit autotools git-2
+
+DESCRIPTION="A flexible OpenVPN plugin to handle user using a MySQL database backend"
+HOMEPAGE="https://github.com/alexxy/openvpn-mysql-auth"
+SRC_URI=""
+EGIT_REPO_URI="
+ git://github.com/alexxy/openvpn-mysql-auth.git
+ https://github.com/alexxy/openvpn-mysql-auth.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ net-misc/openvpn
+ virtual/mysql
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # disable -Werror
+ sed -e 's:-Werror::g' \
+ -i configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ default
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+ dodoc -r example
+}