summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/imaplib2/imaplib2-2.57.0_pre20210322.ebuild22
-rw-r--r--dev-python/imaplib2/metadata.xml15
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/imaplib2/imaplib2-2.57.0_pre20210322.ebuild b/dev-python/imaplib2/imaplib2-2.57.0_pre20210322.ebuild
new file mode 100644
index 0000000..aab0c6d
--- /dev/null
+++ b/dev-python/imaplib2/imaplib2-2.57.0_pre20210322.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Threaded Python IMAP4 client."
+HOMEPAGE="https://github.com/jazzband/imaplib2"
+EGIT_REPO_URI="https://github.com/jazzband/${PN}.git"
+EGIT_COMMIT="08e267c2cdfa189b4bdfa138d7143ad247e2ca2a"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ sed -i "/version=/ s/\"\(.*\)\"/\"${PV}\"/" setup.py
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/imaplib2/metadata.xml b/dev-python/imaplib2/metadata.xml
new file mode 100644
index 0000000..82d81a8
--- /dev/null
+++ b/dev-python/imaplib2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">imaplib2</remote-id>
+ <remote-id type="github">jazzband/imaplib2</remote-id>
+ </upstream>
+</pkgmetadata>