summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/imaplib2/imaplib2-2.57.0_pre20210322.ebuild')
-rw-r--r--dev-python/imaplib2/imaplib2-2.57.0_pre20210322.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/imaplib2/imaplib2-2.57.0_pre20210322.ebuild b/dev-python/imaplib2/imaplib2-2.57.0_pre20210322.ebuild
new file mode 100644
index 0000000..aab0c6d
--- /dev/null
+++ b/dev-python/imaplib2/imaplib2-2.57.0_pre20210322.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Threaded Python IMAP4 client."
+HOMEPAGE="https://github.com/jazzband/imaplib2"
+EGIT_REPO_URI="https://github.com/jazzband/${PN}.git"
+EGIT_COMMIT="08e267c2cdfa189b4bdfa138d7143ad247e2ca2a"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ sed -i "/version=/ s/\"\(.*\)\"/\"${PV}\"/" setup.py
+ distutils-r1_src_prepare
+}