summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Marichez <falco@gentoo.org>2008-08-20 01:14:03 +0200
committerRaphaël Marichez <falco@gentoo.org>2008-08-20 01:14:03 +0200
commit7f57738e4614f5d3293d3aa1ac1d5993b8c04674 (patch)
tree77228d299c043776ae233ff40c63aab972fcef3e
parentMerge commit 'origin/master' (diff)
downloadfalco-7f57738e4614f5d3293d3aa1ac1d5993b8c04674.tar.gz
falco-7f57738e4614f5d3293d3aa1ac1d5993b8c04674.tar.bz2
falco-7f57738e4614f5d3293d3aa1ac1d5993b8c04674.zip
new package: wyd.pl, password profiler for pentesting
Signed-off-by: Raphaël Marichez <falco@gentoo.org>
-rw-r--r--net-analyzer/wyd/ChangeLog7
-rw-r--r--net-analyzer/wyd/Manifest4
-rw-r--r--net-analyzer/wyd/metadata.xml17
-rw-r--r--net-analyzer/wyd/wyd-0.2.ebuild45
4 files changed, 73 insertions, 0 deletions
diff --git a/net-analyzer/wyd/ChangeLog b/net-analyzer/wyd/ChangeLog
new file mode 100644
index 0000000..ba321e1
--- /dev/null
+++ b/net-analyzer/wyd/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-analyzer/wyd
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 19 Aug 2008; Raphael Marichez <falco@gentoo.org> ChangeLog:
+ Initial commit
+
diff --git a/net-analyzer/wyd/Manifest b/net-analyzer/wyd/Manifest
new file mode 100644
index 0000000..4ffb18a
--- /dev/null
+++ b/net-analyzer/wyd/Manifest
@@ -0,0 +1,4 @@
+DIST wyd-0.2.tar.gz 16659 RMD160 64f475cf912c64566ff43eaa779eb2a34e9adc4e SHA1 45d8bceb158f0f0864be77b0869cc463f6813dc0 SHA256 70085fcfa8bfff41d6b6bb4522d9437ad62262ab39fa98d3d8076d54bb06dcb9
+EBUILD wyd-0.2.ebuild 1103 RMD160 63c586809e5e7f1d7b26ebba1cfd3e4646f2e030 SHA1 879d9e33121bbcf3c1bee41b08ab8664d044723f SHA256 04a845ec9bcde7401ccb7ebb95fb30db1e0032bb068fa38a03c07eaaf4b8f0c4
+MISC ChangeLog 197 RMD160 f7da661fe69bfbdbe8b536278c286c53efe17322 SHA1 495add63892f6439d90f373938630e7bc1e4207d SHA256 40a6a6bf59b7cd14b23a0470a2824c0b93789010a4d0bdd2948cdd6260256aab
+MISC metadata.xml 720 RMD160 88f97552461bf72357c3f130fae7a702b71e761e SHA1 b435e207ced1007cbe51bd0f688a1498af00a4e3 SHA256 6cf589397d1ab2a97a7f8c85d19e3be9f3dbeb4d3382ed9d47b81912dcaca979
diff --git a/net-analyzer/wyd/metadata.xml b/net-analyzer/wyd/metadata.xml
new file mode 100644
index 0000000..2eef820
--- /dev/null
+++ b/net-analyzer/wyd/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd></herd>
+ <maintainer>
+ <email>falco@gentoo.org</email>
+ <name>Raphael Marichez</name>
+ </maintainer>
+ <longdescription lang="en">Wyd, the password profiler, is a tool for creating a dictionnary aimed at a specific target person or system</longdescription>
+ <use>
+ <flag name='catdoc'>Installs catdoc for scanning .doc and .ppt files too</flag>
+ <flag name='jhead'>Installs jhead for scanning .jp(e)g files too</flag>
+ <flag name='mp3info'>Installs mp3info for scanning .mp3 files too</flag>
+ <flag name='xpdf'>Installs xpdf for scanning .pdf files too</flag>
+ </use>
+</pkgmetadata>
+
diff --git a/net-analyzer/wyd/wyd-0.2.ebuild b/net-analyzer/wyd/wyd-0.2.ebuild
new file mode 100644
index 0000000..9d791fd
--- /dev/null
+++ b/net-analyzer/wyd/wyd-0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit perl-module
+
+DESCRIPTION="A password profiler"
+HOMEPAGE="http://www.remote-exploit.org/codes_wyd.html"
+SRC_URI="http://www.remote-exploit.org/codes/wyd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="catdoc jhead mp3info xpdf"
+#IUSE="catdoc jhead mp3info pdf oodoc"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ catdoc? ( app-text/catdoc )
+ jhead? ( media-gfx/jhead )
+ mp3info? ( media-sound/mp3info )
+ xpdf? ( app-text/xpdf )"
+
+src_install() {
+ exeinto /usr/bin
+ doexe wyd.pl
+ dodoc BUGS TODO README CHANGES || die
+ docinto docs
+ dodoc docs/* || die
+ insinto "/usr/share/doc/${P}/testfiles"
+ doins testfiles/* || die
+
+ perlinfo
+
+ insinto "${VENDOR_LIB}/wlgmod"
+ doins wlgmod/*.pm
+
+ elog "Be aware that wyd will try to call wlgmod::odt, which needs"
+ elog "OpenOffice::OODoc (http://www.cpan.org/modules/index.html)."
+ elog "wyd.pl will bails, that's normal."
+ elog "You can help in integrating all the features of wyd by porting"
+ elog "OpenOffice::OODoc to Gentoo."
+
+}
+