summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2018-09-21 06:14:55 +0200
committerHans de Graaff <hans@degraaff.org>2018-09-21 06:14:55 +0200
commit6221113ab1382571d606a5be1522df790b18d3bd (patch)
tree69ba99b33b3d11e3ff894d3c776e1c3bef5a978e
parentdev-ruby/rspec-activemodel-mocks: add 1.1.0 (diff)
downloadgraaff-6221113ab1382571d606a5be1522df790b18d3bd.tar.gz
graaff-6221113ab1382571d606a5be1522df790b18d3bd.tar.bz2
graaff-6221113ab1382571d606a5be1522df790b18d3bd.zip
dev-ruby/rubocop: cleanup
Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--dev-ruby/rubocop/Manifest2
-rw-r--r--dev-ruby/rubocop/rubocop-0.58.0.ebuild44
-rw-r--r--dev-ruby/rubocop/rubocop-0.58.1.ebuild44
3 files changed, 0 insertions, 90 deletions
diff --git a/dev-ruby/rubocop/Manifest b/dev-ruby/rubocop/Manifest
index 1b3d7733..c4ee8ac1 100644
--- a/dev-ruby/rubocop/Manifest
+++ b/dev-ruby/rubocop/Manifest
@@ -1,5 +1,3 @@
DIST rubocop-0.57.2.tar.gz 1658831 BLAKE2B 85ff823d4f21709b41ed14d58fa8d98e79c5372882a90d8e53a9fd1a641e5b2ad973c2cc8288921ffcd33dec988fd0f505c0a17acf99358d85d9673c1a8705de SHA512 79986bc564215cd6fc03397c2e33adc11f74d1453a73f4f682956dae00e68c9437b0a2fdb1dd52e34622d74fe781e7a8ec9d8af5122ae72e48a5a7984ff662e2
-DIST rubocop-0.58.0.tar.gz 1664969 BLAKE2B ce17987395f2a9affb99613b0b8c840a4914ebb295cb0c70e49b3beeb3d826ef5c6ac36a91f882006ed1197d960acd9b0bdb0caa1ead7438367eaa298e544277 SHA512 debd2c38f06e6375e00889b18055005aeb6f7e6b725e55b0459e50c2cff0a9535f98a7e8deab0d246561450fe2a682853e40814a581e5620cf502ed5f2d84985
-DIST rubocop-0.58.1.tar.gz 1665854 BLAKE2B 82482d59e50c55bb349fcc15ac527b7361d07b3e2945eae8015f1b3944fcd4c1b4d75ee0ec3059157f8bc87a586521836ac0622abb750c94358a130bf71c8818 SHA512 6976272994719f7f3198e08f4260c39a8869ae07169b0907b5a526a989748e7608f5fc0a4cea7797669cd741cd904d0d912c0eb5c1f0d18c76914a4ca93c6de9
DIST rubocop-0.58.2.tar.gz 1669468 BLAKE2B 305cd7f18d8d1fbd234120b07415881f9866227d0c70fd453a4526e145c4debcbf019f0871e550cf6dd32d159f77375ae66684e0b86718a77db6c6688534559f SHA512 3f1366fd7904979c7807ac061930e42d297a2d64d8cbe021156b244072bcc58a5d116459e956e46634f8d0fb55bec52979bb1acfca718ab991995fd02f48bbd2
DIST rubocop-0.59.0.tar.gz 1682559 BLAKE2B 460ad0cd596ab8a9d1a06e56711ac3fa1eb20a8dbbdfae052bd376c0ea40f487ee8c265803736550d3193862c05b1253421fcca77064641b3ae39b4d537d1ac5 SHA512 17100230a47b776bd1c297c94953934514299ac94d5f457b567a791b381d471a01845f7ee0c4617be46246116a722f6a32768e4bbbafb4e5d5e45d630f77a7e4
diff --git a/dev-ruby/rubocop/rubocop-0.58.0.ebuild b/dev-ruby/rubocop/rubocop-0.58.0.ebuild
deleted file mode 100644
index cdac626d..00000000
--- a/dev-ruby/rubocop/rubocop-0.58.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRAINSTALL="assets config"
-RUBY_FAKEGEM_BINDIR="exe"
-
-inherit eapi7-ver ruby-fakegem
-
-DESCRIPTION="A Ruby static code analyzer"
-HOMEPAGE="https://github.com/bbatsov/rubocop"
-SRC_URI="https://github.com/bbatsov/rubocop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- =dev-ruby/jaro_winkler-1.5*
- >=dev-ruby/parallel-1.10:1
- >=dev-ruby/parser-2.5:0
- >=dev-ruby/powerpack-0.1:0
- >=dev-ruby/rainbow-2.2.2:2
- >=dev-ruby/ruby-progressbar-1.7:0
- >=dev-ruby/unicode-display_width-1.0.1:1"
-
-ruby_add_bdepend "test? ( dev-ruby/safe_yaml dev-ruby/webmock )"
-
-all_ruby_prepare() {
- sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
-
- # Remove failing spec, to be investigated later.
- rm spec/rubocop/formatter/json_formatter_spec.rb || die
-
- sed -i -e 's:/tmp/example:'${TMPDIR}'/example:' spec/rubocop/cop/team_spec.rb || die
-}
diff --git a/dev-ruby/rubocop/rubocop-0.58.1.ebuild b/dev-ruby/rubocop/rubocop-0.58.1.ebuild
deleted file mode 100644
index cdac626d..00000000
--- a/dev-ruby/rubocop/rubocop-0.58.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRAINSTALL="assets config"
-RUBY_FAKEGEM_BINDIR="exe"
-
-inherit eapi7-ver ruby-fakegem
-
-DESCRIPTION="A Ruby static code analyzer"
-HOMEPAGE="https://github.com/bbatsov/rubocop"
-SRC_URI="https://github.com/bbatsov/rubocop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- =dev-ruby/jaro_winkler-1.5*
- >=dev-ruby/parallel-1.10:1
- >=dev-ruby/parser-2.5:0
- >=dev-ruby/powerpack-0.1:0
- >=dev-ruby/rainbow-2.2.2:2
- >=dev-ruby/ruby-progressbar-1.7:0
- >=dev-ruby/unicode-display_width-1.0.1:1"
-
-ruby_add_bdepend "test? ( dev-ruby/safe_yaml dev-ruby/webmock )"
-
-all_ruby_prepare() {
- sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
-
- # Remove failing spec, to be investigated later.
- rm spec/rubocop/formatter/json_formatter_spec.rb || die
-
- sed -i -e 's:/tmp/example:'${TMPDIR}'/example:' spec/rubocop/cop/team_spec.rb || die
-}