summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2022-07-28 08:41:59 +0200
committerHans de Graaff <hans@degraaff.org>2022-07-28 08:41:59 +0200
commit6e1a44368ac4d74ff8e936e8f5c433f7a82b0dfb (patch)
treea75868f7930afb38855f085604a9c386a202f342
parentdev-ruby/tinymce-rails: add 6.1.1 (diff)
downloadgraaff-6e1a44368ac4d74ff8e936e8f5c433f7a82b0dfb.tar.gz
graaff-6e1a44368ac4d74ff8e936e8f5c433f7a82b0dfb.tar.bz2
graaff-6e1a44368ac4d74ff8e936e8f5c433f7a82b0dfb.zip
dev-ruby/authlogic-oid: remove obsolete package
Signed-off-by: Hans de Graaff <hans@degraaff.org>
-rw-r--r--dev-ruby/authlogic-oid/Manifest1
-rw-r--r--dev-ruby/authlogic-oid/authlogic-oid-1.0.4-r4.ebuild41
-rw-r--r--dev-ruby/authlogic-oid/files/authlogic-oid-1.0.4-open_id_authentication.patch38
-rw-r--r--dev-ruby/authlogic-oid/files/authlogic-oid-1.0.4-rails51.patch10
-rw-r--r--dev-ruby/authlogic-oid/metadata.xml5
5 files changed, 0 insertions, 95 deletions
diff --git a/dev-ruby/authlogic-oid/Manifest b/dev-ruby/authlogic-oid/Manifest
deleted file mode 100644
index b2667f63..00000000
--- a/dev-ruby/authlogic-oid/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST authlogic-oid-1.0.4.tgz 11212 BLAKE2B edd638d9a060d74eeecc49dc73079f1180a7890c936c375da0e81363746925abe40b834be60fc6946eb751e5a43c04bdd2aa204f1ca335b5460585ba9da5fadc SHA512 b8609aba2b1bb436c982b76af32dd648bd1cd93c2b2e59db3b4b3558f91e35e9c20d415dddee8f207b095dc9d3e16c02f4794e0f058d7b080a708abc70388747
diff --git a/dev-ruby/authlogic-oid/authlogic-oid-1.0.4-r4.ebuild b/dev-ruby/authlogic-oid/authlogic-oid-1.0.4-r4.ebuild
deleted file mode 100644
index 6b8fbad1..00000000
--- a/dev-ruby/authlogic-oid/authlogic-oid-1.0.4-r4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Extension of the Authlogic library to add OpenID support."
-HOMEPAGE="http://authlogic-oid.rubyforge.org/"
-LICENSE="MIT"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE=""
-
-# Use a fork in the network that has many, many bug fixes and seems the
-# most coherent fork
-#SRC_URI="https://github.com/whitequark/authlogic_openid/tarball/0a5b3772437ac0ebb3b5ecd7ce53f51688d60345 -> ${P}.tgz"
-SRC_URI="http://moving-innovations.com/~graaff/authlogic-oid-1.0.4.tgz"
-RUBY_S="whitequark-authlogic_openid-*"
-
-# Tests use hardcoded path to authlogic
-RESTRICT="test"
-
-ruby_add_bdepend "doc? ( dev-ruby/hoe )"
-
-ruby_add_rdepend ">=dev-ruby/authlogic-3.8:*"
-
-all_ruby_prepare() {
- # Remove reference to documenation template we don't have.
- sed -i -e 's/-T hanna//' Rakefile || die
-
- eapply "${FILESDIR}/${P}-rails51.patch"
-}
diff --git a/dev-ruby/authlogic-oid/files/authlogic-oid-1.0.4-open_id_authentication.patch b/dev-ruby/authlogic-oid/files/authlogic-oid-1.0.4-open_id_authentication.patch
deleted file mode 100644
index 6158e2c9..00000000
--- a/dev-ruby/authlogic-oid/files/authlogic-oid-1.0.4-open_id_authentication.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-commit 9b802c347f5addebcbce945af3b5f80b3ee7b214
-Author: Michael Reinsch <michael@mobalean.com>
-Date: Wed Mar 17 20:14:44 2010 +0900
-
- use OpenID to do the URL normalization; this isn't in the rails plugin anymore
-
-diff --git a/lib/authlogic_openid/acts_as_authentic.rb b/lib/authlogic_openid/acts_as_authentic.rb
-index 11f6fc2..7745299 100644
---- a/lib/authlogic_openid/acts_as_authentic.rb
-+++ b/lib/authlogic_openid/acts_as_authentic.rb
-@@ -53,9 +53,9 @@ module AuthlogicOpenid
-
- # Set the openid_identifier field and also resets the persistence_token if this value changes.
- def openid_identifier=(value)
-- write_attribute(:openid_identifier, value.blank? ? nil : OpenIdAuthentication.normalize_identifier(value))
-+ write_attribute(:openid_identifier, value.blank? ? nil : OpenID.normalize_url(value))
- reset_persistence_token if openid_identifier_changed?
-- rescue OpenIdAuthentication::InvalidOpenId => e
-+ rescue OpenID::DiscoveryFailure => e
- @openid_error = e.message
- end
-
-diff --git a/lib/authlogic_openid/session.rb b/lib/authlogic_openid/session.rb
-index 1052c5b..9a348c3 100644
---- a/lib/authlogic_openid/session.rb
-+++ b/lib/authlogic_openid/session.rb
-@@ -48,9 +48,9 @@ module AuthlogicOpenid
- end
-
- def openid_identifier=(value)
-- @openid_identifier = value.blank? ? nil : OpenIdAuthentication.normalize_identifier(value)
-+ @openid_identifier = value.blank? ? nil : OpenID.normalize_url(value)
- @openid_error = nil
-- rescue OpenIdAuthentication::InvalidOpenId => e
-+ rescue OpenID::DiscoveryFailure => e
- @openid_identifier = nil
- @openid_error = e.message
- end
diff --git a/dev-ruby/authlogic-oid/files/authlogic-oid-1.0.4-rails51.patch b/dev-ruby/authlogic-oid/files/authlogic-oid-1.0.4-rails51.patch
deleted file mode 100644
index 0bfe10d4..00000000
--- a/dev-ruby/authlogic-oid/files/authlogic-oid-1.0.4-rails51.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/lib/authlogic_openid/acts_as_authentic.rb.~1~ 2011-07-17 21:45:44.000000000 +0200
-+++ b/lib/authlogic_openid/acts_as_authentic.rb 2018-06-29 14:05:47.350679614 +0200
-@@ -81,7 +81,6 @@
- def save(options={}, &block)
- return false if options[:validate] != false && block_given? && authenticate_with_openid? && !authenticate_with_openid
- result = super
-- yield(result) if block_given?
- result
- end
-
diff --git a/dev-ruby/authlogic-oid/metadata.xml b/dev-ruby/authlogic-oid/metadata.xml
deleted file mode 100644
index bd70e455..00000000
--- a/dev-ruby/authlogic-oid/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version = '1.0' encoding = 'UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person"><email>graaff@gentoo.org</email></maintainer>
-</pkgmetadata>