summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2017-06-24 08:54:37 +0200
committerHans de Graaff <hans@degraaff.org>2017-06-24 08:54:37 +0200
commitab1d44ef71730db8dd885914ff932386f2df16e8 (patch)
tree05e864c0e01d3f46f1c89dd8101bbeded4af1f23
parentdev-util/reviewboard: add 2.5.13 (diff)
downloadgraaff-ab1d44ef71730db8dd885914ff932386f2df16e8.tar.gz
graaff-ab1d44ef71730db8dd885914ff932386f2df16e8.tar.bz2
graaff-ab1d44ef71730db8dd885914ff932386f2df16e8.zip
dev-util/reviewboard: add 2.5.13.1
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-util/reviewboard/Manifest1
-rw-r--r--dev-util/reviewboard/reviewboard-2.5.13.1.ebuild124
2 files changed, 125 insertions, 0 deletions
diff --git a/dev-util/reviewboard/Manifest b/dev-util/reviewboard/Manifest
index 5c96cf6a..12195501 100644
--- a/dev-util/reviewboard/Manifest
+++ b/dev-util/reviewboard/Manifest
@@ -1,4 +1,5 @@
DIST ReviewBoard-2.5.10.tar.gz 13291368 SHA256 4140079eab1d1c7fc95d877a9542b21522b66ef38178b5cc057d5b3d2335c3ca SHA512 cbd9239a8cda2ef2781fe50fd41a324e0e659f0e4527795bfda378fb8899cde92732db44f9e1d8d097db7d8b3aa60aec578e49ee41490b1744fe841c65f89981 WHIRLPOOL 95d6bd8335bf4211f75e4fd4cc029c62789267c754cb74fac8f063ed8f97fb30805a94c48d3368f726b15834569aff49b07778f8ca3d04fc8162a09b6f540fe8
DIST ReviewBoard-2.5.12.tar.gz 13601747 SHA256 15df245923636902c9160245e29f99ce6b9d3e691278f93bf8fce2d3e172c1f6 SHA512 c82e605a71a17293d9e3b357bd0f740f530b1125e2acf57c56e4b446469152c44c909bffe419f4759674f101122301c36d145b3a674681ac9a56c412a52b2345 WHIRLPOOL 2abdf355b25939af7c0ad3b5504f31ba770a6cf23fe21adf61c59f17720feb784d7320bdbaf4973f6de3ab0535fbf1234a6080b72280ecbf1397c269cbd22ff8
+DIST ReviewBoard-2.5.13.1.tar.gz 13605695 SHA256 164ed85cdbe7b39c8a1ffe57615911bdfd67f78d86af07c113733fdd3ace7230 SHA512 ff9ba0f3e8de40ba9f9ac26fd760f4f3b930d512052712cdf27b9f0f477fb52508299ea52af99db4248f8494b1951a3154a8271bbb08abc83d8f6c7efa330155 WHIRLPOOL 7bf487ddfcaea02d6fc7f11ada46c43fe67e9ee196f2a3ad0d894cf4336552e95f63d40d0d5046a5c6fce1358f723b67188d161a6d97bb8c39831d9f7170e7f3
DIST ReviewBoard-2.5.13.tar.gz 13604255 SHA256 00a2415da9a7bbc88c619dae599cf2ae1a4c4f9aea51dff6f0ca75e76e035b8d SHA512 3f9cb7c8f4c2ae9c8b40d823727516bb8deab939567c4416228cf60f1d114fbff9c8a75681bfe58befe1975ebb28a3324b19064d8721209539b074decc802ac9 WHIRLPOOL 15cc6524779d28ce0cf14d9c8b062ddfba2417f789bcee920ecb633009ac7b3c3a6f667fb540feb56097185724ca819cf3037723789db51e324dcfddc9f8f3d8
DIST ReviewBoard-2.5.9.tar.gz 13240019 SHA256 b688f6842967c5739b39539d8e0e52753a7434994365b13106959909ea1f9a6e SHA512 7fa4aa4b0bbcab592177af9ae82c2cb67903df9318a15722c0fe8ed79fc12db8186266393a95e7a8eac4041238cc5bdb18ed2e40ebfb377adc801266cf2a70d3 WHIRLPOOL b2bcb1fc515e2251d2fcbf4229dc179ebd8a6f89a8c81732b2bec288da0968688cf947cd3ff1879edf3a5265f81f8b48f8ba610ac67845ba817fa35a440c61bc
diff --git a/dev-util/reviewboard/reviewboard-2.5.13.1.ebuild b/dev-util/reviewboard/reviewboard-2.5.13.1.ebuild
new file mode 100644
index 00000000..371dbec6
--- /dev/null
+++ b/dev-util/reviewboard/reviewboard-2.5.13.1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_PN="ReviewBoard"
+DESCRIPTION="A web-based code review tool that offers developers a way to handle code reviews"
+HOMEPAGE="https://www.reviewboard.org/"
+SRC_URI="https://downloads.reviewboard.org/releases/${MY_PN}/2.5/${MY_PN}-${PV}.tar.gz"
+KEYWORDS="~amd64"
+IUSE="codebase doc manual ldap rnotes test"
+
+LICENSE="MIT"
+SLOT="0"
+S=${WORKDIR}/${MY_PN}-${PV}
+
+RDEPEND=">=dev-python/django-1.6.11.1[${PYTHON_USEDEP},sqlite]
+ <dev-python/django-1.7[${PYTHON_USEDEP},sqlite]
+ >=dev-python/django-evolution-0.7.7[${PYTHON_USEDEP}]
+ <dev-python/django-evolution-0.8[${PYTHON_USEDEP}]
+ >=dev-python/django-haystack-2.3.1[${PYTHON_USEDEP}]
+ <dev-python/django-haystack-2.5[${PYTHON_USEDEP}]
+ dev-python/django-multiselectfield[${PYTHON_USEDEP}]
+ >=dev-python/Djblets-0.9.8[${PYTHON_USEDEP}]
+ <dev-python/Djblets-0.10[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.1[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.6.0[${PYTHON_USEDEP}]
+ <dev-python/markdown-2.7[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-1.12[${PYTHON_USEDEP}]
+ >=dev-python/mimeparse-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
+ dev-python/python-memcached[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2015.2[${PYTHON_USEDEP}]
+ dev-python/recaptcha-client[${PYTHON_USEDEP}]
+ >=dev-python/whoosh-2.6[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.1[${PYTHON_USEDEP}]
+ ldap? ( >=dev-python/python-ldap-2.4.21[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="doc? ( || ( codebase manual rnotes ) )"
+# Tests mostly access the inet and when run mostly fail
+RESTRICT=test
+
+python_prepare_all() {
+ # Running uglify is a problem right now, so skip this step. Rather
+ # have newer versions than compacted javascript.
+ sed -e "s/'pipeline.compressors.uglifyjs.UglifyJSCompressor'/None/" -i reviewboard/settings.py || die
+
+ # Use newer markdown version still available
+ sed -i -e '/markdown/ s/2.4/2.6/g' reviewboard/dependencies.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # See https://code.google.com/p/reviewboard/issues/ #3009
+ # until build of manual can find and use ROOT_URLCONF, only possible build path for manual
+ # requires sacrificing the resources section, all of which call on ROOT_URLCONF
+ local msg="Generating docs for"
+ if use doc; then
+ if use manual; then
+ rm -rf docs/manual/webapi//2.0/resources/ || die
+ einfo;einfo "$msg manual"
+ DJANGO_SETTINGS_MODULE="django.conf" emake -C docs/manual html
+ fi
+
+ if use codebase; then
+ pushd docs/codebase &> /dev/null
+ ln -sf ../../contrib/internal/conf/settings_local.py .
+ popd &> /dev/null
+ einfo;einfo "$msg codebase"
+ emake -C docs/codebase html
+ fi
+
+ if use rnotes; then
+ einfo;einfo "$msg release notes"
+ emake -C docs/releasenotes html
+ fi
+ fi
+}
+
+python_test() {
+ pushd ${PN} > /dev/null
+ ln -sf contrib/internal/conf/settings_local.py .
+ "${PYTHON}" manage.py test || die
+}
+
+python_install_all() {
+ if use doc; then
+ if use manual; then
+ insinto /usr/share/doc/${PF}/manual
+ doins -r docs/manual/_build/html/
+ fi
+ if use codebase; then
+ insinto /usr/share/doc/${PF}/codebase
+ doins -r docs/codebase/_build/html/
+ fi
+ if use rnotes; then
+ insinto /usr/share/doc/${PF}/release_notes
+ doins -r docs/releasenotes/_build/html/
+ fi
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "You must install any VCS tool you wish ${PN} to support."
+ elog "dev-util/cvs, dev-vcs/git, dev-vcs/mercurial or dev-util/subversion."
+ elog
+ elog "Install dev-python/mysql-python for mysql support."
+ elog "Install dev-python/psycopg for postgres support."
+ elog
+ elog "For speed and responsiveness, consider installing net-misc/memcached"
+ elog "and dev-python/python-memcached"
+}