summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2019-04-11 17:17:46 +0200
committerHans de Graaff <hans@degraaff.org>2019-04-11 17:17:46 +0200
commitd6931058c3f730be0d1ba514adfa8ae9cf498c3a (patch)
tree532607b8e9f230037f7f254229f3fb4486cb3b6c
parentdev-ruby/iniparse: initial import (diff)
downloadgraaff-d6931058c3f730be0d1ba514adfa8ae9cf498c3a.tar.gz
graaff-d6931058c3f730be0d1ba514adfa8ae9cf498c3a.tar.bz2
graaff-d6931058c3f730be0d1ba514adfa8ae9cf498c3a.zip
dev-vcs/overcommit: add 0.47.0
Signed-off-by: Hans de Graaff <hans@degraaff.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--dev-vcs/overcommit/Manifest1
-rw-r--r--dev-vcs/overcommit/overcommit-0.47.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-vcs/overcommit/Manifest b/dev-vcs/overcommit/Manifest
index c015c79e..2a22f658 100644
--- a/dev-vcs/overcommit/Manifest
+++ b/dev-vcs/overcommit/Manifest
@@ -1 +1,2 @@
+DIST overcommit-0.47.0.tar.gz 183523 BLAKE2B b6a5c04a2fb71762f45d743bc340798c70a4915acfd567515b834f69efd1f14e59af5e9793e5f932741c1ba20f1d14d536ad0fc827119fa91b43af1b4e535987 SHA512 e3fc9c92a9a77bc75649b8a28b6b51acc314ee097d42d51c3158da146f82a08223f969df1745bf8a576e1f0dc7ce83d99a2243c68a9d1391e15ab572626d63d8
DIST overcommit-0.8.0.tar.gz 39398 BLAKE2B 3cdc97cf72b6bffba38574174b5a65b41a62b6395ca28ab39ed194c17429ae6bd4a21036935d04f2a98193d70c4cf16b3dc446333979b488bee10f0eddcd4319 SHA512 9929f06fb9ea85fd75c08230e0f07693285fd8c85ed696ae1ccd0cf1384922c30acd17409fca6aee65d0b71b9a41463b80f9efca5cda60a8d929ce1bc4be7dff
diff --git a/dev-vcs/overcommit/overcommit-0.47.0.ebuild b/dev-vcs/overcommit/overcommit-0.47.0.ebuild
new file mode 100644
index 00000000..7cd26428
--- /dev/null
+++ b/dev-vcs/overcommit/overcommit-0.47.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="config libexec template-dir"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Opinionated Git Hook Manager"
+HOMEPAGE="http://causes.github.io/blog/2013/05/30/overcommit-the-opinionated-git-hook-manager/"
+SRC_URI="https://github.com/causes/overcommit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/childprocess-0.6.3:2
+ >=dev-ruby/iniparse-1.4:1
+"