summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2018-06-12 15:03:04 +0200
committerHans de Graaff <hans@degraaff.org>2018-06-12 15:03:04 +0200
commitf01ab7221a1e8a2ad86f845d024681de35cd4c12 (patch)
tree101f54a3c9279c27df5a8d7b57608f8c218e772c
parentdev-ruby/secure_headers: add 6.0.0 (diff)
downloadgraaff-f01ab7221a1e8a2ad86f845d024681de35cd4c12.tar.gz
graaff-f01ab7221a1e8a2ad86f845d024681de35cd4c12.tar.bz2
graaff-f01ab7221a1e8a2ad86f845d024681de35cd4c12.zip
dev-ruby/premailer-rails: install VERSION file
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-ruby/premailer-rails/premailer-rails-1.10.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/premailer-rails/premailer-rails-1.10.2-r1.ebuild b/dev-ruby/premailer-rails/premailer-rails-1.10.2-r1.ebuild
new file mode 100644
index 00000000..33e67133
--- /dev/null
+++ b/dev-ruby/premailer-rails/premailer-rails-1.10.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+# rspec3 but requires bundler and thus has dependency complications
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The power of the premailer gem to Rails without any configuration needs"
+HOMEPAGE="https://github.com/fphilipe/premailer-rails"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="1"
+IUSE="test"
+
+ruby_add_rdepend "
+ <dev-ruby/actionmailer-6:*
+ >=dev-ruby/premailer-1.7.9:1
+"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/nokogiri )
+"
+
+all_ruby_prepare() {
+ sed -i -e '/if RUBY_ENGINE/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}