summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rubocop-performance/rubocop-performance-1.19.1.ebuild')
-rw-r--r--dev-ruby/rubocop-performance/rubocop-performance-1.19.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/rubocop-performance/rubocop-performance-1.19.1.ebuild b/dev-ruby/rubocop-performance/rubocop-performance-1.19.1.ebuild
new file mode 100644
index 00000000..2b4f5c6e
--- /dev/null
+++ b/dev-ruby/rubocop-performance/rubocop-performance-1.19.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="config"
+
+RUBY_FAKEGEM_GEMSPEC="rubocop-performance.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of RuboCop cops to check for performance optimizations in Ruby code"
+HOMEPAGE="https://github.com/rubocop/rubocop-performance/"
+SRC_URI="https://github.com/rubocop/rubocop-performance/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/rubocop-1.7.0:0
+ >=dev-ruby/rubocop-ast-0.4.0
+"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rubocop-1.13.0 )"