summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/rubocop-performance/Manifest1
-rw-r--r--dev-ruby/rubocop-performance/rubocop-performance-1.19.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/rubocop-performance/Manifest b/dev-ruby/rubocop-performance/Manifest
index ae4147d3..2d18df33 100644
--- a/dev-ruby/rubocop-performance/Manifest
+++ b/dev-ruby/rubocop-performance/Manifest
@@ -1 +1,2 @@
DIST rubocop-performance-1.17.1.tar.gz 103876 BLAKE2B 7c654f61510d90517dbbaf4699801964518670dd655d1930f7bb6fd3fa8add3501c0813615be4848e3c2c59a347e4fc1ad3ab17c12d0c9e96fbe7a67d59e9545 SHA512 3f2faa0da9976151059c47e2f3aad44f1d207df694ec8ca1bc9e42409b82dfbd2c4ee2ae697cd38d523f8de5a31bb830e76fb7c2eb4ef43fe31df3e988bbeef1
+DIST rubocop-performance-1.19.1.tar.gz 102853 BLAKE2B 4e1d9f800e661d84258aa0324acdbe2bd41e6cefc4311066f557543bbaed8e1333de620fd35b5b944539d3c5f9784e309a7531b952b8aa1337cb655b160bb571 SHA512 011296ab11a0dca60c5df577efc09d54ef0af5a457ee8e78a697866b74c31f883c65b6c2131ea94e7cba75a481712626fd498498aab02f1a745de67f371440ef
diff --git a/dev-ruby/rubocop-performance/rubocop-performance-1.19.1.ebuild b/dev-ruby/rubocop-performance/rubocop-performance-1.19.1.ebuild
new file mode 100644
index 00000000..2b4f5c6e
--- /dev/null
+++ b/dev-ruby/rubocop-performance/rubocop-performance-1.19.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="config"
+
+RUBY_FAKEGEM_GEMSPEC="rubocop-performance.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of RuboCop cops to check for performance optimizations in Ruby code"
+HOMEPAGE="https://github.com/rubocop/rubocop-performance/"
+SRC_URI="https://github.com/rubocop/rubocop-performance/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/rubocop-1.7.0:0
+ >=dev-ruby/rubocop-ast-0.4.0
+"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rubocop-1.13.0 )"