summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesús Guerrero <i92guboj@gentoo.org>2008-05-07 16:05:22 +0000
committerJesús Guerrero <i92guboj@gentoo.org>2008-05-07 16:05:22 +0000
commit9cfa4d6c6c3b47f31e7312de1ba02f84c1f86c76 (patch)
treeb8737a79cf330521b53644e433decdf6cc702e6d
parentMany various small changes and cleanup. (diff)
downloadomp-9cfa4d6c6c3b47f31e7312de1ba02f84c1f86c76.tar.gz
omp-9cfa4d6c6c3b47f31e7312de1ba02f84c1f86c76.tar.bz2
omp-9cfa4d6c6c3b47f31e7312de1ba02f84c1f86c76.zip
version bump to 2.5.26
svn path=/; revision=16
-rw-r--r--x11-wm/fvwm/Manifest2
-rw-r--r--x11-wm/fvwm/fvwm-2.5.26.ebuild160
2 files changed, 162 insertions, 0 deletions
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index 59d6bc0..803cf36 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -4,6 +4,8 @@ AUX VerticalSeparatorMargins.patch 3456 RMD160 95e2134f8596b1e73b3f09a92e635c9bc
AUX fvwm-2.5.23-translucent-menus.diff 15765 RMD160 5629e1fcd6d41e7c9f5cfa0a62204d33d83d5c6f SHA1 2ff0c394e1e393cab8249efeeddf917d07a7ba78 SHA256 ad59f0aa1b73fb128143bf5a390185289c296e0d31a4e6e6ca5f046f414752cf
AUX fvwm-menu-xlock-xlockmore-compat.patch 550 RMD160 72af6f306e5869581fcd48c84edfe00adea4a5b9 SHA1 0eccf83c3046e3822737c5facb23f547a062bff8 SHA256 5db8bc279f618096b23fed04b70b626c6ff50c104283d5ece505200db1e5a8af
DIST fvwm-2.5.25.tar.bz2 2516717 RMD160 bf77786a071838304eb4bf8cc14960196c235506 SHA1 8e0f0b1eb888f7fcc27a0dbcc32a5b0f2895df2b SHA256 212dafb5fbace4a72d7a2d2dd6df7445709bad6739162a72879e4a6e942d69fc
+DIST fvwm-2.5.26.tar.bz2 2509177 RMD160 47be927e61ef5411b668baec0e9a00d5691b3784 SHA1 26d9054c0f148a397eeaa9939be9329fb002831f SHA256 84aca15165f600c5c09095c94b3ad1f0bfe16ba25cf2097f76312a0fba89251d
DIST fvwm-patchset-20070901-r2.tar.bz2 37255 RMD160 787fe6f49e497a225648dbdd30b0636d3416a5b0 SHA1 9d56b1f2703feb52987e6aeb22dc151bc0e10d67 SHA256 9342142d216ca5b89c161a9796a08c4effc1b3d8dd41090e3419b051fac639fa
EBUILD fvwm-2.5.25.ebuild 4422 RMD160 d052e5cbc8e6de455d6dc7fde785d6ad0de42017 SHA1 6d93b42cc8d23dda028fc329e24bfd91778e198d SHA256 c1c0fb5601d2c5b6852e2da903eeb1eb680af59e3e10458d74303db00b393450
+EBUILD fvwm-2.5.26.ebuild 4422 RMD160 d052e5cbc8e6de455d6dc7fde785d6ad0de42017 SHA1 6d93b42cc8d23dda028fc329e24bfd91778e198d SHA256 c1c0fb5601d2c5b6852e2da903eeb1eb680af59e3e10458d74303db00b393450
EBUILD fvwm-9999.ebuild 6985 RMD160 fadfaa9ca384911f2a5930991a494c7ea80754ca SHA1 60c6c84d287b3c6c4fa2249bc8b7e1c816f8d0f2 SHA256 b7a725d6bd63582a89cfde414263acdf9b2c1709180039fce96d2273176e63a2
diff --git a/x11-wm/fvwm/fvwm-2.5.26.ebuild b/x11-wm/fvwm/fvwm-2.5.26.ebuild
new file mode 100644
index 0000000..9b68653
--- /dev/null
+++ b/x11-wm/fvwm/fvwm-2.5.26.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="An extremely powerful ICCCM-compliant multiple virtual desktop window manager"
+HOMEPAGE="http://www.fvwm.org/"
+SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2"
+
+LICENSE="GPL-2 FVWM"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bidi debug doc gtk imlib nls perl png readline rplay stroke svg tk truetype vanilla xinerama"
+
+RDEPEND="dev-lang/perl
+ sys-libs/zlib
+ x11-libs/libXpm
+ x11-libs/libXft
+ bidi? ( dev-libs/fribidi )
+ gtk? (
+ =x11-libs/gtk+-1.2*
+ imlib? ( media-libs/imlib )
+ )
+ perl? ( tk? (
+ dev-lang/tk
+ dev-perl/perl-tk
+ >=dev-perl/X11-Protocol-0.56
+ )
+ )
+ png? ( media-libs/libpng )
+ readline? (
+ sys-libs/ncurses
+ sys-libs/readline
+ )
+ rplay? ( media-sound/rplay )
+ stroke? ( dev-libs/libstroke )
+ svg? ( gnome-base/librsvg )
+ truetype? (
+ media-libs/fontconfig
+ virtual/xft
+ )
+ userland_GNU? ( sys-apps/debianutils )
+ xinerama? ( x11-libs/libXinerama )"
+# XXX: gtk2 perl bindings require dev-perl/gtk2-perl, worth a dependency?
+# XXX: gtk perl bindings require dev-perl/gtk-perl, worth a dependency?
+# XXX: netpbm is used by FvwmScript-ScreenDump, worth a dependency?
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/pkgconfig
+ x11-libs/libXrandr
+ x11-proto/xextproto
+ x11-proto/xproto
+ doc? ( dev-libs/libxslt )
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_unpack() {
+ unpack ${A}
+
+ if ! use vanilla; then
+ cd "${S}"
+
+ # this patch enables fast translucent menus in fvwm. this is a
+ # minor tweak of a patch posted to fvwm-user mailing list by Olivier
+ # Chapuis in <20030827135125.GA6370@snoopy.folie>.
+ epatch "${FILESDIR}/fvwm-2.5.23-translucent-menus.diff"
+
+ # This is a gentoo-specific trivial patch
+ epatch "${FILESDIR}/fvwm-menu-xlock-xlockmore-compat.patch"
+ fi
+}
+
+src_compile() {
+ local myconf="--libexecdir=/usr/lib --with-imagepath=/usr/include/X11/bitmaps:/usr/include/X11/pixmaps:/usr/share/icons/fvwm --enable-package-subdirs --without-gnome"
+
+ # Non-upstream email where bugs should be sent; used in fvwm-bug.
+ export FVWM_BUGADDR="desktop-wm@gentoo.org"
+
+ # Recommended by upstream.
+ append-flags -fno-strict-aliasing
+
+ # Signed chars are required.
+ use ppc && append-flags -fsigned-char
+
+ if use gtk; then
+ if ! use imlib; then
+ einfo "ATTN: You can safely ignore any imlib related configure errors."
+ myconf="${myconf} --with-imlib-prefix=${T}"
+ fi
+ else
+ myconf="${myconf} --disable-gtk"
+ fi
+
+ use readline && myconf="${myconf} --without-termcap-library"
+
+ econf ${myconf} \
+ $(use_enable bidi) \
+ $(use_enable debug debug-msgs) \
+ $(use_enable debug command-log) \
+ $(use_enable doc htmldoc) \
+ $(use_enable nls) \
+ $(use_enable nls iconv) \
+ $(use_enable perl perllib) \
+ $(use_with png png-library) \
+ $(use_with readline readline-library) \
+ $(use_with rplay rplay-library) \
+ $(use_with stroke stroke-library) \
+ $(use_enable svg rsvg) \
+ $(use_enable truetype xft) \
+ $(use_enable xinerama) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use perl; then
+ local toolkits="gtk tcltk"
+
+ if ! use tk; then
+ rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/Tk.pm"
+ toolkits=${toolkits/tcltk/}
+ fi
+
+ if ! use gtk; then
+ rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/"Gtk{,2}.pm
+ toolkits=${toolkits/gtk/}
+ fi
+
+ if ! test "${toolkits// /}"; then
+ rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/Toolkit.pm"
+ find "${D}/usr/share/fvwm/perllib" -depth -type d -exec rmdir {} \; 2>/dev/null
+ fi
+ else
+ rm -rf "${D}/usr/bin/fvwm-perllib" \
+ "${D}/usr/share/man/man1/fvwm-perllib.1"
+ fi
+
+ # Utility for testing FVWM behaviour by creating a simple window with
+ # configurable hints.
+ if use debug; then
+ dobin "${S}/tests/hints/hints_test"
+ newdoc "${S}/tests/hints/README" README.hints
+ fi
+
+ # Remove fvwm-convert-2.6 as it does not contain any code.
+ rm -f "${D}/usr/bin/fvwm-convert-2.6" \
+ "${D}/usr/share/man/man1/fvwm-convert-2.6.1"
+
+ echo "/usr/bin/fvwm" > "${D}/etc/X11/Sessions/${PN}"
+
+ dodoc AUTHORS ChangeLog NEWS README \
+ docs/{ANNOUNCE,BUGS,COMMANDS,CONVENTIONS} \
+ docs/{DEVELOPERS,error_codes,FAQ,TODO,fvwm.lsm}
+
+ # README file for translucent menus patch.
+ use vanilla || dodoc "${FILESDIR}/README.translucency"
+}