summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-06-11 13:17:59 +0200
committerTomas Chvatal <scarabeus@gentoo.org>2011-06-11 13:17:59 +0200
commit809b6f1e3e4be9ee8f28530b29111e6d6ff835f4 (patch)
tree835a89931173bbf9bece5e39c43a8337e700a112 /sys-boot/grub/grub-9999.ebuild
parent[sys-boot/grub] fully support side-by-side install with old grub. (diff)
downloadscarabeus-809b6f1e3e4be9ee8f28530b29111e6d6ff835f4.tar.gz
scarabeus-809b6f1e3e4be9ee8f28530b29111e6d6ff835f4.tar.bz2
scarabeus-809b6f1e3e4be9ee8f28530b29111e6d6ff835f4.zip
[sys-boot/grub] Rename efi cutting so it does not break qemu targets. Add loongson target for live version as yeelong was renamed.
Diffstat (limited to 'sys-boot/grub/grub-9999.ebuild')
-rw-r--r--sys-boot/grub/grub-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index c229a4c..7ae0b4e 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -26,17 +26,17 @@ SLOT="2"
[[ ${PV} != "9999" ]] && KEYWORDS="~amd64 ~x86 ~mips ~ppc ~ppc64"
IUSE="custom-cflags debug device-mapper nls static sdl truetype"
-GRUB_PLATFORMS="coreboot efi-32 efi-64 emu ieee1275 multiboot pc qemu qemu-mips yeeloong"
+GRUB_PLATFORMS="coreboot efi_32 efi_64 emu ieee1275 multiboot pc qemu qemu-mips loongson"
# everywhere:
# emu
# mips only:
-# qemu-mips, yeelong
+# qemu-mips, loongson
# amd64, x86, ppc, ppc64
# ieee1275
# amd64, x86
-# coreboot, multiboot, efi-32, pc, qemu
+# coreboot, multiboot, efi_32, pc, qemu
# amd64
-# efi-64
+# efi_64
for i in ${GRUB_PLATFORMS}; do
IUSE+=" grub_platforms_${i}"
done
@@ -132,16 +132,16 @@ grub_src_configure() {
# check if we have to specify the target (EFI)
# or just append correct --with-platform
if [[ -n ${platform} ]]; then
- if [[ ${platform/-*} == ${platform} ]]; then
+ if [[ ${platform/_*} == ${platform} ]]; then
platform=" --with-platform=${platform}"
else
# EFI platform hack
- [[ ${platform/*-} == 32 ]] && target=i386
- [[ ${platform/*-} == 64 ]] && target=x86_64
+ [[ ${platform/*_} == 32 ]] && target=i386
+ [[ ${platform/*_} == 64 ]] && target=x86_64
# program-prefix is required empty because otherwise it is equal to
# target variable, which we do not want at all
platform="
- --with-platform=${platform/-*}
+ --with-platform=${platform/_*}
--target=${target}
--program-prefix=
"