summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2009-09-03 16:57:03 +0000
committerAndreas Proschofsky <suka@gentoo.org>2009-09-03 16:57:03 +0000
commit30b306fd513ac75a59eaef59280beff29e1b3f86 (patch)
tree4da625feae4158f739dccda66cfdaffcfbcf984b
parentRemoving gnome-main-menu stuff, not using it anymore, so won't maintain (diff)
downloadsuka-30b306fd513ac75a59eaef59280beff29e1b3f86.tar.gz
suka-30b306fd513ac75a59eaef59280beff29e1b3f86.tar.bz2
suka-30b306fd513ac75a59eaef59280beff29e1b3f86.zip
Add (masked) live ebuilds for gir-repository and gobject-introspection
svn path=/; revision=151
-rw-r--r--dev-libs/gir-repository/Manifest1
-rw-r--r--dev-libs/gir-repository/gir-repository-9999.ebuild91
-rw-r--r--dev-libs/gobject-introspection/Manifest3
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-0.6.4.ebuild6
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-9999.ebuild39
-rw-r--r--profiles/package.mask2
6 files changed, 137 insertions, 5 deletions
diff --git a/dev-libs/gir-repository/Manifest b/dev-libs/gir-repository/Manifest
index 25f29a7..259fc25 100644
--- a/dev-libs/gir-repository/Manifest
+++ b/dev-libs/gir-repository/Manifest
@@ -1,3 +1,4 @@
AUX gir-repository-0.6.3-fix-worlds-worst-automagic-configure.patch 17076 RMD160 f73c364dbea9e55da5eac2941e709a2482705ea5 SHA1 906b93e77ec4697a6cf9baa2c63d336509d35fe0 SHA256 af8d42db6dbff99895ec70d3e416e3f3f7b2b237bfa55cddd163066c7c858f7f
DIST gir-repository-0.6.4.tar.bz2 264515 RMD160 c22453e4f7609720624b7a0f9a60a3ca04716982 SHA1 d78d2ce407d7d48f5be36f2bd6c74fafd7335ce1 SHA256 34660fc9fd43a04227b8bd52a609c4f928dc5df0b03dbe06bb56d3dfd1b64738
EBUILD gir-repository-0.6.4.ebuild 2339 RMD160 766c60cc496cc91ba18e8483e185f81b737b08aa SHA1 151b15a20e63c8ece6ca60963d2177acd9a95bc7 SHA256 eceada94acdd8ccc6cc019e3ec87e12f50b8c8db03b01d65686823f2a2d74010
+EBUILD gir-repository-9999.ebuild 2338 RMD160 6eb24238ef3e00d0121816c986d1d64ff018af67 SHA1 df959742ba1cb7ca4380d605d703c9b7f45a193d SHA256 64c1f553760c1ceabb96e7ac71787c2ce674d81b91b230f889a8ae04d22cf6bc
diff --git a/dev-libs/gir-repository/gir-repository-9999.ebuild b/dev-libs/gir-repository/gir-repository-9999.ebuild
new file mode 100644
index 0000000..345775b
--- /dev/null
+++ b/dev-libs/gir-repository/gir-repository-9999.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2 git
+
+EGIT_REPO_URI="git://git.gnome.org/gir-repository"
+
+DESCRIPTION="Gobject-Introspection file Repository"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+SRC_URI=""
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atk avahi babl dbus gconf gnome-keyring gstreamer +gtk gtksourceview gupnp
+libnotify libsoup libunique libwnck pango poppler vte webkit"
+
+RDEPEND=">=dev-libs/gobject-introspection-0.6.3"
+DEPEND="${RDEPEND}
+ atk? ( >=dev-libs/atk-1.12.0 )
+ avahi? ( >=net-dns/avahi-0.6 )
+ babl? ( media-libs/babl )
+ dbus? ( dev-libs/dbus-glib )
+ gconf? ( gnome-base/gconf )
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ goocanvas? ( x11-libs/goocanvas )
+ gstreamer? (
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10 )
+ gtk? (
+ >=dev-libs/atk-1.12.0
+ x11-libs/gtk+:2 )
+ gtksourceview? ( x11-libs/gtksourceview )
+ gupnp? (
+ net-libs/gssdp
+ net-libs/gupnp )
+ libnotify? ( x11-libs/libnotify )
+ libsoup? ( net-libs/libsoup:2.4 )
+ libunique? ( >=dev-libs/libunique-1.0.0 )
+ libwnck? ( x11-libs/libwnck )
+ nautilus? ( gnome-base/nautilus )
+ pango? ( x11-libs/pango )
+ poppler? ( >=virtual/poppler-glib-0.8 )
+ vte? ( x11-libs/vte )
+ webkit? ( >=net-libs/webkit-gtk-1.0 )
+"
+
+pkg_setup() {
+ # FIXME: installs even disabled stuff if it's a dependency of something enabled
+ # XXX: Seemingly unrelated enabling is for Makefile-level dependencies
+ # FIXME: Above mentioned dependencies are incomplete
+ G2CONF="${G2CONF}
+ --disable-clutter
+ --disable-clutter-gtk
+ --disable-clutter-cairo
+ --disable-gnio
+ $(use_enable atk)
+ $(use_enable avahi)
+ $(use_enable babl)
+ $(use_enable dbus)
+ $(use_enable gconf)
+ $(use_enable gnome-keyring gnomekeyring)
+ $(use_enable goocanvas)
+ $(use_enable gstreamer)
+ $(use_enable gtk)
+ $(use_enable gtk atk)
+ $(use_enable gtksourceview)
+ $(use_enable gupnp gssdp)
+ $(use_enable libnotify notify)
+ $(use_enable libsoup soup)
+ $(use_enable libunique unique)
+ $(use_enable libwnck wnck)
+ $(use_enable nautilus)
+ $(use_enable pango)
+ $(use_enable poppler)
+ $(use_enable vte)
+ $(use_enable webkit)
+ $(use_enable webkit soup)
+ "
+}
+
+src_unpack() {
+ git_src_unpack
+ cd ${S}
+ eautoreconf
+}
diff --git a/dev-libs/gobject-introspection/Manifest b/dev-libs/gobject-introspection/Manifest
index 6830ef8..37da5d8 100644
--- a/dev-libs/gobject-introspection/Manifest
+++ b/dev-libs/gobject-introspection/Manifest
@@ -2,4 +2,5 @@ AUX gobject-introspection-0.6.2-gir.patch 432 RMD160 f159e05133c1ba71061c9e111cf
AUX gobject-introspection-0.6.4-gir-export.patch 1585 RMD160 d2dde4b4dfcbb917263a79672ead2186525a9db6 SHA1 e344ea1f41d85e4df291821c3d9b1546a9df70a3 SHA256 7e5be6f42333594fe9a2b2a1307c2fa418f68052f59cd257921def311e211f52
AUX gobject-introspection-0.6.4-libtool.patch 674 RMD160 7cbb7074b878b5ebbcb70cf71592b32d150ebbfe SHA1 278321eb086f459db59a2a5f60b446312a6aa30c SHA256 b2fb65fbac1809663f931f214a572aec924c37c5b8c57db5b7a12459e1a6e9d7
DIST gobject-introspection-0.6.4.tar.bz2 608062 RMD160 b8f12297ebd982ec5a5f7be0829cd13cee3ab5a3 SHA1 07ff1f8b9f59c844a543fde8d48cbf60a22e5c27 SHA256 6ca9cf935dd553e4e7f6c93361e8218886837d93d76a68a54fcfcc601ee57059
-EBUILD gobject-introspection-0.6.4.ebuild 1061 RMD160 6bb97f178f54a03501b82d5e20893b31eddea95c SHA1 2309a941a6bca4142d5af021dde7f73b28909e76 SHA256 cded1c5abeded169b3a525f4968c27b6a72be1548d56ba53cff08a78014473d8
+EBUILD gobject-introspection-0.6.4.ebuild 1013 RMD160 e4753d64c226fbac5c0f170bfc86aee521c23508 SHA1 bab050c573c81591f4ab16c29f52def2259af396 SHA256 e8d1b5ddf13c3fe791a2c41cb04bb614a215497b8062a6841a6f6e6df75373e5
+EBUILD gobject-introspection-9999.ebuild 714 RMD160 8925d74967f2bc25305cb2622122860740d31a8a SHA1 f23a2aae752945fd950b71087f8bbe073e2a22f1 SHA256 7a637f15d94281b0acbc9570134c495a2f4575223cd9bcf6e5d2d0fd7e576f9f
diff --git a/dev-libs/gobject-introspection/gobject-introspection-0.6.4.ebuild b/dev-libs/gobject-introspection/gobject-introspection-0.6.4.ebuild
index bf8e685..7c8bf23 100644
--- a/dev-libs/gobject-introspection/gobject-introspection-0.6.4.ebuild
+++ b/dev-libs/gobject-introspection/gobject-introspection-0.6.4.ebuild
@@ -6,13 +6,13 @@ EAPI="2"
inherit autotools gnome2 eutils
-DESCRIPTION="The GObject introspection"
+DESCRIPTION="GObject Introspection tools and library"
HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
LICENSE="LGPL-2 GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="" # doc
+IUSE=""
RDEPEND=">=dev-libs/glib-2.19.0
|| (
@@ -22,8 +22,6 @@ RDEPEND=">=dev-libs/glib-2.19.0
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.18
sys-devel/flex"
-# No 1.12 release yet
-# doc? ( dev-util/gtk-doc-1.12 )"
G2CONF="${G2CONF}
--disable-gtk-doc
diff --git a/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild b/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
new file mode 100644
index 0000000..a351f5e
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools gnome2 git
+
+EGIT_REPO_URI="git://git.gnome.org/gobject-introspection"
+
+DESCRIPTION="GObject Introspection tools and library"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+SRC_URI=""
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.19.0
+ || (
+ sys-devel/gcc[libffi]
+ virtual/libffi )
+ >=dev-lang/python-2.5"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ >=dev-util/pkgconfig-0.18
+ sys-devel/flex"
+
+G2CONF="${G2CONF}
+--disable-gtk-doc
+--disable-static"
+
+src_unpack() {
+ git_src_unpack
+ cd ${S}
+ gtkdocize
+ eautoreconf
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 0d7ec12..2aca61e 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -13,6 +13,8 @@
=gnome-extra/gnome-main-menu-9999
# Live ebuilds for GNOME Shell stuff
+=dev-libs/gir-repository-9999
=dev-libs/gjs-9999
+=dev-libs/gobject-introspection-9999
=gnome-base/gnome-shell-9999
=x11-wm/mutter-9999