summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycups/pycups-1.9.46.ebuild')
-rw-r--r--dev-python/pycups/pycups-1.9.46.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pycups/pycups-1.9.46.ebuild b/dev-python/pycups/pycups-1.9.46.ebuild
new file mode 100644
index 0000000..522df68
--- /dev/null
+++ b/dev-python/pycups/pycups-1.9.46.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/pycups-1.9.45-r1.ebuild,v 1.2 2009/06/12 14:07:43 scarabeus Exp $
+
+NEED_PYTHON="2.4"
+inherit distutils flag-o-matic
+
+DESCRIPTION="Python bindings for the CUPS API"
+HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
+SRC_URI="http://cyberelk.net/tim/data/pycups/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ net-print/cups
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc )
+"
+
+src_compile() {
+ append-cflags -DVERSION=\\\"${PV}\\\"
+ distutils_src_compile
+
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r html/ || die "installing html docs failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/"${P}"
+ doins -r examples/ || die "installing examples failed"
+ fi
+
+}