summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2019-01-13 16:54:23 +0100
committerUltrabug <ultrabug@gentoo.org>2019-01-13 16:54:23 +0100
commita4d3096fb4da23d231adfb1604055558c8cda30c (patch)
tree34e430f70b58d6169a11563620927d8de3e9dc68 /net-misc/postman-bin/postman-bin-6.7.1.ebuild
parentapp-admin/scylla-tools: version bump (diff)
downloadultrabug-a4d3096fb4da23d231adfb1604055558c8cda30c.tar.gz
ultrabug-a4d3096fb4da23d231adfb1604055558c8cda30c.tar.bz2
ultrabug-a4d3096fb4da23d231adfb1604055558c8cda30c.zip
net-misc/postman-bin: new package
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Manifest-Sign-Key: F30FAFEE3BD598228B24CB121A3A8C89C56D610B Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'net-misc/postman-bin/postman-bin-6.7.1.ebuild')
-rw-r--r--net-misc/postman-bin/postman-bin-6.7.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/postman-bin/postman-bin-6.7.1.ebuild b/net-misc/postman-bin/postman-bin-6.7.1.ebuild
new file mode 100644
index 0000000..7cc74c9
--- /dev/null
+++ b/net-misc/postman-bin/postman-bin-6.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+MY_PN=${PN/-bin/}
+
+inherit eutils
+
+DESCRIPTION="Supercharge your API workflow"
+HOMEPAGE="https://www.getpostman.com/"
+SRC_URI="https://dl.pstmn.io/download/version/${PV}/linux64 -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="MPL-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="gnome-base/gconf"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/Postman/app"
+
+src_install() {
+ insinto /opt/${MY_PN}
+ doins -r *
+
+ exeinto /opt/${MY_PN}
+ doexe Postman
+
+ dosym /opt/${MY_PN}/Postman /usr/bin/${MY_PN}
+
+ newicon -s 128 "${S}/resources/app/assets/icon.png" postman.png
+
+ make_desktop_entry "postman" \
+ "Postman" \
+ "/usr/share/icons/hicolor/128x128/apps/postman.png" \
+ "Development" \
+ "Comment=Postman API IDE"
+}