aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-10-20 20:06:56 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-10-20 20:06:56 +0100
commitef839047331b1fa2b44472e522235350e6cfe28c (patch)
treea43a926429fda678ff3f19976905f7600ece0959 /Makefile
parentwrappers: use @TOPDIR@ and @PREFIX@ instead of __TOPDIR__ and __PREFIX__ (diff)
downloadcrossdev-ef839047331b1fa2b44472e522235350e6cfe28c.tar.gz
crossdev-ef839047331b1fa2b44472e522235350e6cfe28c.tar.bz2
crossdev-ef839047331b1fa2b44472e522235350e6cfe28c.zip
Makefile: avoid '//' when PREFIX is not set
PREFIX assumes leading '/'. Thus the idiom is $(DESTDIR)$(PREFIX)/foo and not $(DESTDIR)/$(PREFIX)/foo Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 7814eaf..aa07a91 100644
--- a/Makefile
+++ b/Makefile
@@ -6,9 +6,9 @@ include settings.mk
all:
install:
- $(INSTALL_DIR) $(DESTDIR)/$(PREFIX)/bin/
- $(INSTALL_EXEC) crossdev $(DESTDIR)/$(PREFIX)/bin/
- sed -i -e "s:@GENTOO_PORTAGE_EPREFIX@:$(EPREFIX):g" $(DESTDIR)/$(PREFIX)/bin/crossdev
+ $(INSTALL_DIR) $(DESTDIR)$(PREFIX)/bin/
+ $(INSTALL_EXEC) crossdev $(DESTDIR)$(PREFIX)/bin/
+ sed -i -e "s:@GENTOO_PORTAGE_EPREFIX@:$(EPREFIX):g" $(DESTDIR)$(PREFIX)/bin/crossdev
$(MAKE) -C wrappers install
PV = $(shell test -e .git && date --date="`git log -1 --format=%ci`" +%Y%m%d)