summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2018-12-01 18:03:47 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2018-12-01 18:40:47 +0300
commitda8de29ef14ab32f06ec865b05e4863a55b16cbb (patch)
tree32d04ab4083ecf5f18c31ace9ca8e355e0b9a676
parentgames-sports/stuntrally: additional fixes (diff)
downloadgamerlay-da8de29ef14ab32f06ec865b05e4863a55b16cbb.tar.gz
gamerlay-da8de29ef14ab32f06ec865b05e4863a55b16cbb.tar.bz2
gamerlay-da8de29ef14ab32f06ec865b05e4863a55b16cbb.zip
games-sports/stuntrally-tracks: add version 2.6
Fixes for live ebuild, remove deprecated eclasses Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--games-sports/stuntrally-tracks/Manifest1
-rw-r--r--games-sports/stuntrally-tracks/stuntrally-tracks-2.6.ebuild29
-rw-r--r--games-sports/stuntrally-tracks/stuntrally-tracks-9999.ebuild12
-rw-r--r--games-sports/stuntrally/stuntrally-2.6.ebuild1
-rw-r--r--games-sports/stuntrally/stuntrally-9999.ebuild1
5 files changed, 36 insertions, 8 deletions
diff --git a/games-sports/stuntrally-tracks/Manifest b/games-sports/stuntrally-tracks/Manifest
new file mode 100644
index 0000000..05f990d
--- /dev/null
+++ b/games-sports/stuntrally-tracks/Manifest
@@ -0,0 +1 @@
+DIST stuntrally-tracks-2.6.tar.gz 355793120 SHA256 4bce700516a2a178ac04cfbf7df2887ba42225802f5a3e670f770ea01345687b SHA512 f3b46381230a92e36c99e1cb2a6e625e9cc9bb3ecd60b76227f790e81caf7b91ed0a2e7abc48793d14fc60ad50d35de2b31c284587ad9ffbca5870a328795513 WHIRLPOOL 9a1dc3881988dbf645b5589b3cc121c7363d03b520ab0e20c3bbef875d70d6cae217468bf83f1ad972b898651a571313caa5d1921f23d9e3f47438fd37d30fb8
diff --git a/games-sports/stuntrally-tracks/stuntrally-tracks-2.6.ebuild b/games-sports/stuntrally-tracks/stuntrally-tracks-2.6.ebuild
new file mode 100644
index 0000000..fe2ff9d
--- /dev/null
+++ b/games-sports/stuntrally-tracks/stuntrally-tracks-2.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A set of tracks for ${CATEGORY}/${P//-tracks}"
+HOMEPAGE="http://stuntrally.tuxfamily.org/"
+
+SLOT="0"
+LICENSE="GPL-3"
+IUSE=""
+
+SRC_URI="https://github.com/stuntrally/tracks/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/tracks-${PV}"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DSHARE_INSTALL="/usr/share/stuntrally"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}
diff --git a/games-sports/stuntrally-tracks/stuntrally-tracks-9999.ebuild b/games-sports/stuntrally-tracks/stuntrally-tracks-9999.ebuild
index 58446e2..60248df 100644
--- a/games-sports/stuntrally-tracks/stuntrally-tracks-9999.ebuild
+++ b/games-sports/stuntrally-tracks/stuntrally-tracks-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit games cmake-utils git-2
+inherit cmake-utils git-r3
DESCRIPTION="A set of tracks for ${CATEGORY}/${P//-tracks}"
-HOMEPAGE="http://code.google.com/p/vdrift-ogre/"
+HOMEPAGE="https://stuntrally.tuxfamily.org/"
SLOT="0"
LICENSE="GPL-3"
@@ -19,17 +19,13 @@ EGIT_PROJECT="${PN}"
# Shallowing, since we don't want to fetch few GB of history
#EGIT_OPTIONS="--depth 1"
-RDEPEND="~${CATEGORY}/${P//-tracks}"
-DEPEND="${RDEPEND}"
-
src_configure() {
local mycmakeargs+=(
- -DSHARE_INSTALL="/usr/share/games/stuntrally"
+ -DSHARE_INSTALL="/usr/share/stuntrally"
)
cmake-utils_src_configure
}
src_install() {
cmake-utils_src_install
- prepgamesdirs
}
diff --git a/games-sports/stuntrally/stuntrally-2.6.ebuild b/games-sports/stuntrally/stuntrally-2.6.ebuild
index 06b7065..5d2f22d 100644
--- a/games-sports/stuntrally/stuntrally-2.6.ebuild
+++ b/games-sports/stuntrally/stuntrally-2.6.ebuild
@@ -57,6 +57,7 @@ src_configure() {
-DBUILD_GAME=$(usex game)
-DBUILD_EDITOR=$(usex editor)
-DBUILD_SHARED_LIBS=OFF
+ -DSHARE_INSTALL="share/stuntrally"
)
cmake-utils_src_configure
}
diff --git a/games-sports/stuntrally/stuntrally-9999.ebuild b/games-sports/stuntrally/stuntrally-9999.ebuild
index 6e9d7bf..0bd380b 100644
--- a/games-sports/stuntrally/stuntrally-9999.ebuild
+++ b/games-sports/stuntrally/stuntrally-9999.ebuild
@@ -53,6 +53,7 @@ src_configure() {
-DBUILD_GAME=$(usex game)
-DBUILD_EDITOR=$(usex editor)
-DBUILD_SHARED_LIBS=OFF
+ -DSHARE_INSTALL="share/stuntrally"
)
cmake-utils_src_configure
}