aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-03-22 04:56:59 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-03-22 05:00:07 -0700
commit12fa38a1fa44ed435631968f1a82bd24fc0e5dbc (patch)
tree071c036ec634c90623a34fc0b690e95e6745e8f6
parentekeyword: Remove ekeyword symlink (diff)
downloadgentoolkit-12fa38a1fa44ed435631968f1a82bd24fc0e5dbc.tar.gz
gentoolkit-12fa38a1fa44ed435631968f1a82bd24fc0e5dbc.tar.bz2
gentoolkit-12fa38a1fa44ed435631968f1a82bd24fc0e5dbc.zip
ebump: Add to setup.py, minor update to man page
Update script to use VERSION like the other scripts
-rwxr-xr-xbin/ebump7
-rw-r--r--man/ebump.142
-rwxr-xr-xsetup.py2
3 files changed, 27 insertions, 24 deletions
diff --git a/bin/ebump b/bin/ebump
index b129f85..a0d4d56 100755
--- a/bin/ebump
+++ b/bin/ebump
@@ -3,7 +3,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-__version__="0.1.1"
__author__="Karl Trygve Kalleberg"
__email__="<karltk@gentoo.org>"
__description__="Ebuild version bumping tool"
@@ -13,6 +12,8 @@ __description__="Ebuild version bumping tool"
# a given ebuild and auxiliary files in the Portage tree. It is only
# useful for Gentoo developers with CVS commit access.
+VERSION="git"
+
die() {
echo $1 >&2
exit -1
@@ -25,7 +26,7 @@ einfo() {
}
print_version() {
- echo "${__description__}, v${__version__}"
+ echo "${__description__}, v${VERSION}"
echo "Copyright (c) 2004 ${__author__} ${__email__}"
echo "Copyright 1999-2010 Gentoo Foundation"
echo "Distributed under the terms of the GNU General Public License v2"
@@ -33,7 +34,7 @@ print_version() {
print_usage() {
echo "Usage: ebump <options> foo<.ebuild>"
- echo "Ebuild version bumping tool, v${__version__}"
+ echo "Ebuild version bumping tool, v${VERSION}"
echo " -V|--version show version info"
echo " -v|--verbose increase verbosity"
echo " -q|--quiet turn off output"
diff --git a/man/ebump.1 b/man/ebump.1
index b1e473d..1754cf9 100644
--- a/man/ebump.1
+++ b/man/ebump.1
@@ -1,12 +1,12 @@
-.TH "ebump" "1" "0.1.1" "Gentoolkit" "Gentoo Administration"
+.TH "EBUMP" "1" "March 2017" "GENTOOLKIT" "Gentoo Administration"
.SH "NAME"
-.LP
+.LP
ebump \- Gentoo: Ebuild revision bumper
.SH "SYNTAX"
-.LP
+.LP
ebump [\fIoption\fP] <\fIpackage-name[-version]\fP>
-.SH "DESCRIPTION"
+.SH "DESCRIPTION"
.LP
\fIebump\fR bumps the revision of a particular ebuild, and all auxiliary
@@ -15,36 +15,36 @@ files in the files/ directory that have a matching version suffix.
.LP
By default, the all new revision files will be added to the VCS.
-.LP
+.LP
You must stand in the directory of the ebuild to be bumped.
.SH "OPTIONS"
-.LP
+.LP
\fB\-C\fR
.br
\fB--no-vcs\fB
-.IP
+.IP
Do not add new files to VCS.
-.LP
+.LP
\fB\-V\fR
.br
\fB--version\fB
-.IP
+.IP
Display version information and exit.
-.LP
+.LP
\fB\-v\fR
.br
\fB--verbose\fB
-.IP
+.IP
Increase verbosity level. May be used more than once.
-.LP
+.LP
\fB\-q\fR
.br
\fB--quiet\fB
-.IP
+.IP
Do not output any non-essential information.
.LP
@@ -61,19 +61,19 @@ don't bump auxfiles (files/*)
.IP
do not update ChangeLog (via echangelog)
-.LP
+.LP
\fB\-m\fR <\fIChangeLog text\fR>
-.br
+.br
\fB\--message\fR <\fIChangeLog text\fR>
-.IP
+.IP
Specifies the message to add to the ChangeLog, instead of the standard
placeholder.
-.LP
+.LP
\fB\-d\fR
.br
\fB\--delete-old\fR
-.IP
+.IP
Delete old revision and old auxiliary files from VCS. This is
\fIdangerous\fR and should only be used if you know exactly what you are
doing, because
@@ -111,16 +111,16 @@ From these files, \fIebump\fR will load the settings
.br
\fB~/.gentoo/gentool-env\fR
.IR
-From this file, \fIebump\fR will load the env vars \fBAUTHORNAME\fR and
+From this file, \fIebump\fR will load the env vars \fBAUTHORNAME\fR and
\fBAUTHOREMAIL\fR, which are used to generate proper ChangeLog entries.
.SH "SEE ALSO"
-.LP
+.LP
The rest of the utilities in \fIapp-portage/gentoolkit-dev\fR, such as
\fIechangelog(1)\fR and \fIekeyword(1)\fR.
.SH "AUTHORS"
-.LP
+.LP
Karl Trygve Kalleberg <karltk@gentoo.org>
.br
Christian Ruppert <idl0r@gentoo.org>
diff --git a/setup.py b/setup.py
index 024b612..d16a56b 100755
--- a/setup.py
+++ b/setup.py
@@ -30,6 +30,7 @@ except ImportError:
# Bash files that need `VERSION=""` subbed, relative to this dir:
bash_scripts = [(os.path.join(cwd, path), 'VERSION=') for path in (
+ 'bin/ebump',
'bin/euse',
'bin/revdep-rebuild.sh'
)]
@@ -49,6 +50,7 @@ python_scripts = [(os.path.join(cwd, path), '__version__ = ') for path in (
)]
manpages = [(os.path.join(cwd, path[0]), path[1]) for path in (
+ ('man/ebump.1', 'EBUMP'),
('man/eclean.1', 'ECLEAN'),
('man/enalyze.1', 'ENALYZE'),
('man/epkginfo.1', 'EPKGINFO'),