summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-14 13:13:41 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-14 13:17:10 +0100
commit501b49571213af9ffb4953f7bf31f57837b51883 (patch)
tree424da513eddf590ee057701e9d49c53463ae7924
parentgnome-extra/yelp: 3.30 available in ::gentoo (diff)
downloadgnome-501b49571213af9ffb4953f7bf31f57837b51883.tar.gz
gnome-501b49571213af9ffb4953f7bf31f57837b51883.tar.bz2
gnome-501b49571213af9ffb4953f7bf31f57837b51883.zip
gnome-extra/yelp: sync live ebuild with ::gentoo
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Manifest-Sign-Key: 0x5A56C8CD0C13248A Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
-rw-r--r--gnome-extra/yelp/yelp-9999.ebuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/gnome-extra/yelp/yelp-9999.ebuild b/gnome-extra/yelp/yelp-9999.ebuild
index 351c3b1d..0e71ed76 100644
--- a/gnome-extra/yelp/yelp-9999.ebuild
+++ b/gnome-extra/yelp/yelp-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-GCONF_DEBUG="no"
+EAPI=6
+GNOME2_LA_PUNT="yes"
-inherit autotools eutils gnome2
+inherit autotools gnome2
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -18,7 +18,7 @@ IUSE=""
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
fi
RDEPEND="
@@ -28,14 +28,16 @@ RDEPEND="
>=dev-libs/glib-2.38:2
>=dev-libs/libxml2-2.6.5:2
>=dev-libs/libxslt-1.1.4
- >=gnome-extra/yelp-xsl-3.12
- >=net-libs/webkit-gtk-1.3.10:3
+ >=gnome-extra/yelp-xsl-3.27.1
+ >=net-libs/webkit-gtk-2.19.2:4
>=x11-libs/gtk+-3.13.3:3
- x11-themes/gnome-icon-theme-symbolic
+ x11-themes/adwaita-icon-theme
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.13
>=dev-util/intltool-0.41.0
+ dev-util/glib-utils
+ dev-util/itstool
>=sys-devel/gettext-0.17
virtual/pkgconfig
"
@@ -44,14 +46,13 @@ DEPEND="${RDEPEND}
if [[ ${PV} = 9999 ]]; then
DEPEND="${DEPEND}
- app-text/yelp-tools
- dev-util/itstool"
+ app-text/yelp-tools"
fi
src_prepare() {
# Fix compatibility with Gentoo's sys-apps/man
# https://bugzilla.gnome.org/show_bug.cgi?id=648854
- epatch "${FILESDIR}"/${PN}-3.20.0-man-compatibility.patch
+ eapply "${FILESDIR}"/${PN}-3.20.0-man-compatibility.patch
[[ ${PV} != 9999 ]] && eautoreconf
@@ -60,10 +61,16 @@ src_prepare() {
src_configure() {
local myconf=""
- [[ ${PV} != 9999 ]] && myconf="ITSTOOL=$(type -P true)"
+ [[ ${PV} != 9999 ]] && myconf="APPSTREAM_UTIL="
gnome2_src_configure \
--disable-static \
--enable-bz2 \
--enable-lzma \
${myconf}
}
+
+src_install() {
+ gnome2_src_install
+ exeinto /usr/libexec/
+ doexe "${S}"/libyelp/yelp-groff
+}