summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-10-13 11:57:04 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2013-11-15 01:39:11 +0100
commitabffd00fce81f8a81233c78577dd76eec3dda8f0 (patch)
treeb2cf2fbb89fcf7ab0b59f0cdb22354c6fd60f2ef /app-arch
parentmedia-gfx/gnome-font-viewer: 3.8.0 → 3.10.0 (diff)
downloadgnome-abffd00fce81f8a81233c78577dd76eec3dda8f0.tar.gz
gnome-abffd00fce81f8a81233c78577dd76eec3dda8f0.tar.bz2
gnome-abffd00fce81f8a81233c78577dd76eec3dda8f0.zip
app-arch/file-roller: 3.8.4-r1 → 3.10.0
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/Manifest11
-rw-r--r--app-arch/file-roller/file-roller-3.10.0.ebuild102
-rw-r--r--app-arch/file-roller/file-roller-9999.ebuild109
3 files changed, 175 insertions, 47 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
new file mode 100644
index 00000000..6f1f0adb
--- /dev/null
+++ b/app-arch/file-roller/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST file-roller-3.10.0.tar.xz 1389884 SHA256 d889bb9904146e5715c082aa9a6d96b0606a066ba2bf05fbfb7030f2bf274f13 SHA512 9b923284c3268962b7984f0f2ab7dc10d9aea3d6f2638fade6731fb936c9332d1c5a6f296624b1c05a4807cea5053bc3b91cf1fccc290d24c01e86e601b87564 WHIRLPOOL 5845322b28a079b0acadb6ebb02891c74420ee9a2f31a2617137b4421620c567be187ac82f62496219a9fd5aa44b21a67990211b1bd195b0e4cdbb570ab8cf4d
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.21 (GNU/Linux)
+
+iEYEAREKAAYFAlJabnEACgkQ1fmVwcYIWAa0igCgoIZVEZTAB0MrDGoo1EI9QTYY
+CusAoIZOjw/7/Oo4iItfIQuv3AWZ/VOm
+=6U63
+-----END PGP SIGNATURE-----
diff --git a/app-arch/file-roller/file-roller-3.10.0.ebuild b/app-arch/file-roller/file-roller-3.10.0.ebuild
new file mode 100644
index 00000000..40723334
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.10.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 readme.gentoo
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="http://fileroller.sourceforge.net/"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="nautilus packagekit"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.9.3:3
+ >=x11-libs/libnotify-0.4.3:=
+ sys-apps/file
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/pango
+ nautilus? ( >=gnome-base/nautilus-3 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular achive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # Use absolute path to GNU tar since star doesn't have the same
+ # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
+ epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
+
+ # app-arch/{un,}rar-5 support, https://bugzilla.gnome.org/show_bug.cgi?id=707568
+ epatch "${FILESDIR}"/${PN}-3.8.4-rar-5.patch
+
+ # File providing Gentoo package names for various archivers
+ cp -f "${FILESDIR}/3.6.0-packages.match" data/packages.match || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+ # --disable-debug because enabling it adds -O0 to CFLAGS
+ gnome2_src_configure \
+ --disable-run-in-place \
+ --disable-static \
+ --disable-debug \
+ --enable-magic \
+ --enable-libarchive \
+ --with-smclient=xsmp \
+ $(use_enable nautilus nautilus-actions) \
+ $(use_enable packagekit) \
+ ITSTOOL=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/app-arch/file-roller/file-roller-9999.ebuild b/app-arch/file-roller/file-roller-9999.ebuild
index 5e5ecb5e..4a45d613 100644
--- a/app-arch/file-roller/file-roller-9999.ebuild
+++ b/app-arch/file-roller/file-roller-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,7 +6,7 @@ EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit eutils gnome2
+inherit eutils gnome2 readme.gentoo
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -14,36 +14,39 @@ fi
DESCRIPTION="Archive manager for GNOME"
HOMEPAGE="http://fileroller.sourceforge.net/"
-LICENSE="GPL-2+ CCPL-Attribution-ShareAlike-3.0"
+LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
IUSE="nautilus packagekit"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
fi
# gdk-pixbuf used extensively in the source
# cairo used in eggtreemultidnd.c
# pango used in fr-window
-RDEPEND=">=dev-libs/glib-2.29.14:2
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.9.3:3
+ >=x11-libs/libnotify-0.4.3:=
sys-apps/file
x11-libs/cairo
x11-libs/gdk-pixbuf:2
- x11-libs/pango
- x11-libs/libSM
x11-libs/libICE
- >=x11-libs/gtk+-3.4:3
- >=app-arch/libarchive-3:=
- >=x11-libs/libnotify-0.4.3:=
- >=dev-libs/json-glib-0.14
+ x11-libs/libSM
+ x11-libs/pango
nautilus? ( >=gnome-base/nautilus-3 )
packagekit? ( app-admin/packagekit-base )
"
DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
>=dev-util/intltool-0.40.0
sys-devel/gettext
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
# eautoreconf needs:
# gnome-base/gnome-common
@@ -52,50 +55,62 @@ if [[ ${PV} = 9999 ]]; then
app-text/yelp-tools"
fi
-src_prepare() {
- # --disable-debug because enabling it adds -O0 to CFLAGS
- G2CONF="${G2CONF}
- --disable-dependency-tracking
- --disable-run-in-place
- --disable-static
- --disable-debug
- --enable-magic
- --enable-libarchive
- --with-smclient=xsmp
- $(use_enable nautilus nautilus-actions)
- $(use_enable packagekit)"
- [[ ${PV} != 9999 ]] && G2CONF="${G2CONF} ITSTOOL=$(type -P true)"
- DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
-
- gnome2_src_prepare
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular achive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo - app-arch/zoo"
+src_prepare() {
# Use absolute path to GNU tar since star doesn't have the same
# options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
+ # app-arch/{un,}rar-5 support, https://bugzilla.gnome.org/show_bug.cgi?id=707568
+ epatch "${FILESDIR}"/${PN}-3.8.4-rar-5.patch
+
# File providing Gentoo package names for various archivers
cp -f "${FILESDIR}/3.6.0-packages.match" data/packages.match || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+ [[ ${PV} != 9999 ]] && myconf="${myconf} ITSTOOL=$(type -P true)"
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+ # --disable-debug because enabling it adds -O0 to CFLAGS
+ gnome2_src_configure \
+ --disable-run-in-place \
+ --disable-static \
+ --disable-debug \
+ --enable-magic \
+ --enable-libarchive \
+ --with-smclient=xsmp \
+ $(use_enable nautilus nautilus-actions) \
+ $(use_enable packagekit) \
+ ${myconf}
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
}
pkg_postinst() {
gnome2_pkg_postinst
-
- elog "${PN} is a frontend for several archiving utilities. If you want a"
- elog "particular achive format support, see ${HOMEPAGE}"
- elog "and install the relevant package."
- elog
- elog "for example:"
- elog " 7-zip - app-arch/p7zip"
- elog " ace - app-arch/unace"
- elog " arj - app-arch/arj"
- elog " cpio - app-arch/cpio"
- elog " deb - app-arch/dpkg"
- elog " iso - app-cdr/cdrtools"
- elog " jar,zip - app-arch/zip and app-arch/unzip"
- elog " lha - app-arch/lha"
- elog " lzop - app-arch/lzop"
- elog " rar - app-arch/unrar or app-arch/unar"
- elog " rpm - app-arch/rpm"
- elog " unstuff - app-arch/stuffit"
- elog " zoo - app-arch/zoo"
+ readme.gentoo_print_elog
}