aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-06-30 11:34:46 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-06-30 11:35:28 +0200
commit14263b5b782e1870721fbb06ef76c6f7c25301e5 (patch)
tree12cc32e14e739cf775804590f33f03a4acf3d657
parentdev-java/xbeans: treeclean (diff)
downloadjava-14263b5b782e1870721fbb06ef76c6f7c25301e5.tar.gz
java-14263b5b782e1870721fbb06ef76c6f7c25301e5.tar.bz2
java-14263b5b782e1870721fbb06ef76c6f7c25301e5.zip
dev-java/jaminid: treeclean
Reason: failed sourcing ebuild: eutils: EAPI 0 not supported, (eutils.eclass, line 32: called die) Bug: https://bugs.gentoo.org/759889 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/jaminid/Manifest1
-rw-r--r--dev-java/jaminid/files/build.xml19
-rw-r--r--dev-java/jaminid/files/jaminid-0.99-utf8.patch133
-rw-r--r--dev-java/jaminid/jaminid-0.99-r3.ebuild42
-rw-r--r--dev-java/jaminid/metadata.xml8
5 files changed, 0 insertions, 203 deletions
diff --git a/dev-java/jaminid/Manifest b/dev-java/jaminid/Manifest
deleted file mode 100644
index 51a01f7f..00000000
--- a/dev-java/jaminid/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Jaminid-0.99.tgz 127831 SHA256 f9a5924b8c8a11bf2a8bf68f66faa1f0f425a40a8d9e068aadf9006cac7c7795
diff --git a/dev-java/jaminid/files/build.xml b/dev-java/jaminid/files/build.xml
deleted file mode 100644
index 76370194..00000000
--- a/dev-java/jaminid/files/build.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<project name="jaminid" default="jar">
- <target name="init">
- <delete dir="doc"/>
- </target>
- <target name="compile" depends="init">
- <mkdir dir="build"/>
- <javac srcdir="." destdir="build" classpath="${gentoo.classpath}"/>
- </target>
-
- <target name="jar" depends="compile">
- <jar destfile="jaminid.jar" basedir="build"/>
- </target>
-
- <target name="javadoc">
- <mkdir dir="docs"/>
- <javadoc sourcepath="src" destdir="docs" classpath="${gentoo.classpath}"/>
- </target>
-
-</project>
diff --git a/dev-java/jaminid/files/jaminid-0.99-utf8.patch b/dev-java/jaminid/files/jaminid-0.99-utf8.patch
deleted file mode 100644
index 26a61f7d..00000000
--- a/dev-java/jaminid/files/jaminid-0.99-utf8.patch
+++ /dev/null
@@ -1,133 +0,0 @@
-Index: src/com/prolixtech/jaminid/Connection.java
-===================================================================
---- src/com/prolixtech/jaminid/Connection.java (revision 13)
-+++ src/com/prolixtech/jaminid/Connection.java (working copy)
-@@ -3,10 +3,13 @@
- import java.io.IOException;
- import java.io.InputStream;
- import java.io.OutputStream;
-+import java.io.UnsupportedEncodingException;
- import java.net.InetAddress;
- import java.net.Socket;
- import java.text.SimpleDateFormat;
-+import java.util.ArrayList;
- import java.util.Date;
-+import java.util.List;
- import java.util.Locale;
- import java.util.Timer;
- import java.util.TimerTask;
-@@ -82,7 +85,7 @@
-
- CONNECTED:
- while(true){
-- StringBuffer requestInputBuffer = new StringBuffer();
-+ List<Byte> requestInputBuffer = new ArrayList<Byte>();
-
- int byteIn = -1;
- int CRLFState = 0;
-@@ -106,7 +109,7 @@
- byteIn = socketInput.read();
- if (byteIn > 0) {
-
-- requestInputBuffer.append((char) byteIn);
-+ requestInputBuffer.add((byte)byteIn);
- if (doubleCRLFpassed)
- bodyCharsParsed++;
-
-@@ -142,10 +145,10 @@
- if ("\n".charAt(0) == (thischar)) {
- CRLFState++;
- doubleCRLFpassed = true;
-- serviceRequest.addRequestLines(requestInputBuffer
-- .toString());
--
-- requestInputBuffer = new StringBuffer();
-+ String inputString = bytesToString(requestInputBuffer);
-+ serviceRequest.addRequestLines(inputString);
-+
-+ requestInputBuffer = new ArrayList<Byte>();
-
- expectedBodySize = serviceRequest.switchToBody();
- } else {
-@@ -163,8 +166,9 @@
- && bodyCharsParsed < expectedBodySize || doubleCRLFpassed
- && byteIn != -1 && socketInput.available() > 0);
-
-- printlog("Request: " + requestInputBuffer.toString());
-- serviceRequest.addRequestLines(requestInputBuffer.toString());
-+ String inputString = bytesToString(requestInputBuffer);
-+ printlog("Request: " + inputString);
-+ serviceRequest.addRequestLines(inputString);
-
- serviceRequest.switchToCompleted();
-
-@@ -242,6 +246,22 @@
- }
-
- /**
-+ * Added dnaber 2007-06-09, to make UTF-8 input work.
-+ */
-+ private String bytesToString(List<Byte> requestInputBuffer) {
-+ Byte[] b = (Byte[])requestInputBuffer.toArray(new Byte[]{});
-+ byte[] bytes = new byte[b.length];
-+ for (int i = 0; i < b.length; i++) {
-+ bytes[i] = b[i];
-+ }
-+ try {
-+ return new String(bytes, "utf-8");
-+ } catch (UnsupportedEncodingException e) {
-+ throw new RuntimeException(e.toString(), e);
-+ }
-+ }
-+
-+ /**
- * a shortcut method
- *
- * @param message
-@@ -261,7 +281,7 @@
- protected void sendString(Object string) throws IOException {
- if (string == null)
- return;
-- socketOutput.write((string.toString()).getBytes());
-+ socketOutput.write((string.toString()).getBytes("UTF-8"));
- }
-
- protected void sendString(byte[] bytes) {
-Index: src/com/prolixtech/jaminid/Protocol.java
-===================================================================
---- src/com/prolixtech/jaminid/Protocol.java (revision 13)
-+++ src/com/prolixtech/jaminid/Protocol.java (working copy)
-@@ -280,7 +280,7 @@
- MIME.setProperty(".txt", "text/plain");
-
-
--
-+ /* dnaber, 2006-09-16
- try {
- OutputStream nmim = new FileOutputStream(Protocol.MIMEFILE);
- MIME.storeToXML(nmim, "\nJAMINID MIMETYPES\n\nThese are the default MIME types for the jaminid daemon. If you had a modified but invalid MIME file here, it may have been reverted to this.");
-@@ -287,7 +287,8 @@
- } catch (IOException e) {
- // TODO Auto-generated catch block
- e.printStackTrace();
-- }
-+
-+ }*/
-
- }
-
-Index: src/com/prolixtech/jaminid/Request.java
-===================================================================
---- src/com/prolixtech/jaminid/Request.java (revision 13)
-+++ src/com/prolixtech/jaminid/Request.java (working copy)
-@@ -321,8 +321,8 @@
- try {
- String hex = s.substring(lastIndex + 1, lastIndex + 3);
- char hin = (char) hex2int(hex);
-- System.out.println(lastIndex + " Hex is " + hex + " or "
-- + hin);
-+ //System.out.println(lastIndex + " Hex is " + hex + " or "
-+ // + hin);
- String sBefore = s.substring(0, lastIndex);
- String sAfter = s.substring(lastIndex + 3);
-
diff --git a/dev-java/jaminid/jaminid-0.99-r3.ebuild b/dev-java/jaminid/jaminid-0.99-r3.ebuild
deleted file mode 100644
index 96fc1cef..00000000
--- a/dev-java/jaminid/jaminid-0.99-r3.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-JAVA_PKG_IUSE="doc source examples"
-
-inherit eutils java-pkg-2 java-ant-2
-
-MY_PN="Jaminid"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Jaminid is a very small daemon meant to embed in Java applications as an add-on HTTP interface."
-HOMEPAGE="http://jaminid.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
-LICENSE="LGPL-2" #Assuming v2
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=virtual/jre-1.5"
-DEPEND=">=virtual/jdk-1.5"
-
-S="${WORKDIR}/${MY_PN}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}" || die
- mv src/com/prolixtech/jaminid_examples . -v
- epatch "${FILESDIR}"/${P}-utf8.patch
- sed -i -e 's/config\/MIME.XML/\/usr\/share\/jaminid\/config\/MIME.XML/g' src/com/prolixtech/jaminid/Protocol.java
- cp -v "${FILESDIR}"/build.xml . || die
-}
-
-src_install() {
- java-pkg_dojar ${PN}.jar
- insinto /usr/share/jaminid
- doins -r config || die "doins failed."
- use doc && java-pkg_dojavadoc docs
- use source && java-pkg_dosrc src/com
- use examples && java-pkg_doexamples jaminid_examples
- dodoc README.TXT || die
-}
diff --git a/dev-java/jaminid/metadata.xml b/dev-java/jaminid/metadata.xml
deleted file mode 100644
index 952a4b9b..00000000
--- a/dev-java/jaminid/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
-</pkgmetadata>