aboutsummaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-06-26 12:24:07 +0200
committerLars Wendler <polynomial-c@gentoo.org>2010-06-26 12:24:07 +0200
commit9d6f60f207c481cbcc6113f031aad04f7a916ce2 (patch)
tree0f3338baaa826380744deb130bd88dca303379b2 /dev-db
parentff/xul: bump to new nightly, 0dd4e086cea5 (diff)
downloadmozilla-9d6f60f207c481cbcc6113f031aad04f7a916ce2.tar.gz
mozilla-9d6f60f207c481cbcc6113f031aad04f7a916ce2.tar.bz2
mozilla-9d6f60f207c481cbcc6113f031aad04f7a916ce2.zip
Added new local "unlock_notify" USE flag to dev-db/sqlite and let mozilla stuff depend on it.
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/Manifest2
-rw-r--r--dev-db/sqlite/sqlite-3.6.23.1.ebuild13
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-db/sqlite/Manifest b/dev-db/sqlite/Manifest
index 54065818..8099b022 100644
--- a/dev-db/sqlite/Manifest
+++ b/dev-db/sqlite/Manifest
@@ -4,4 +4,4 @@ AUX sqlite-3.6.22-interix-fixes.patch 614 RMD160 0492235d52c003620a84888c36541bd
DIST sqlite-3.6.23.1.tar.gz 3086807 RMD160 03847176d21391cc44d2275fc685d556c56ab9d8 SHA1 718615fc37a5ef57fb4e7d06fc56ee7bda391d6f SHA256 1a0517438a573a68ab73e8ed75d194086d55d75883542ab1d5ae1080bbddd492
DIST sqlite-amalgamation-3.6.23.1.tar.gz 1421265 RMD160 6ab83f464a51b9862970f3473f25839319cdb7d5 SHA1 0f4a1390f6405b8f00ecc3694c99ba4e87b40308 SHA256 d080d724836fb8453dc9f3d5826c097b61e39d121b6c5da7b967764ca1523558
DIST sqlite_docs_3_6_23.zip 2788665 RMD160 ca2674800fcb552af93e37c6cbf41b13d3c1facc SHA1 caef3584c8050a135f11d8809fa9ac7ff9696708 SHA256 21e3ad71475a65c2d14d02c9ed8a7bdc5ed6620d6cc1696e245f9d0bb8b26136
-EBUILD sqlite-3.6.23.1.ebuild 4495 RMD160 1cf1b67f03cd82645b5feb8c34edbb49e501893f SHA1 7303709aad7159cbb7bc48ecff4bfd4092117b04 SHA256 31fb9342fae660da19987d408febcc97a94dd03faf254fbd03b46782ee87083b
+EBUILD sqlite-3.6.23.1.ebuild 4650 RMD160 58807a4ff83e367fc438193ec3dce82e0548f683 SHA1 2c1c48e0d5767f56627c557875bb2c2fc2aa7130 SHA256 4fa3c1e12bbac637ce78b46b727bce0b8a282b15eeafe7f002c93649c0de4ac1
diff --git a/dev-db/sqlite/sqlite-3.6.23.1.ebuild b/dev-db/sqlite/sqlite-3.6.23.1.ebuild
index c6e316b0..98a26ff0 100644
--- a/dev-db/sqlite/sqlite-3.6.23.1.ebuild
+++ b/dev-db/sqlite/sqlite-3.6.23.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.23.ebuild,v 1.2 2010/03/19 18:33:37 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.23.1.ebuild,v 1.4 2010/06/04 19:25:54 phajdan.jr Exp $
EAPI="3"
@@ -21,8 +21,8 @@ SRC_URI="
LICENSE="as-is"
SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc extensions +fts3 icu +readline secure-delete soundex tcl +threadsafe test"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc extensions +fts3 icu +readline secure-delete soundex tcl +threadsafe test unlock_notify"
RDEPEND="icu? ( dev-libs/icu )
readline? ( sys-libs/readline )
@@ -88,6 +88,11 @@ src_configure() {
append-cppflags -DNDEBUG
fi
+ # This is needed by >=www-client/seamonkey-2.1_alpha2
+ if use unlock_notify ; then
+ append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
+ fi
+
local extensions_option
if use tcl || use test; then
extensions_option="load-extension"
@@ -101,7 +106,7 @@ src_configure() {
# only available on OSX starting from 10.6 (Snow Leopard). For earlier
# versions of OSX we have to disable all this nifty locking options, as
# suggested by upstream.
- if [[ ${CHOST} == *-darwin[56789] ]] ; then
+ if [[ "${CHOST}" == *-darwin[56789] ]] ; then
append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE=0
fi