aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-02-01 15:38:05 -0600
committerJory Pratt <anarchy@gentoo.org>2020-02-01 15:38:05 -0600
commit85aaa6a84bc7508ae36a27149da59d81cd56208e (patch)
treec4918e971ab3dfa6552303f4e1bf0cf1653199cb /www-client/firefox
parentwww-client/firefox: Version bump 73.0b11 (diff)
downloadmozilla-85aaa6a84bc7508ae36a27149da59d81cd56208e.tar.gz
mozilla-85aaa6a84bc7508ae36a27149da59d81cd56208e.tar.bz2
mozilla-85aaa6a84bc7508ae36a27149da59d81cd56208e.zip
www-client/firefox: Add system-harfbuzz back to ebuild
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/Manifest2
-rw-r--r--www-client/firefox/firefox-73.0_beta11.ebuild19
-rw-r--r--www-client/firefox/metadata.xml2
3 files changed, 13 insertions, 10 deletions
diff --git a/www-client/firefox/Manifest b/www-client/firefox/Manifest
index bec3d0fb..97076f28 100644
--- a/www-client/firefox/Manifest
+++ b/www-client/firefox/Manifest
@@ -1,2 +1,2 @@
-DIST firefox-73.0-patches-02.tar.xz 17092 BLAKE2B 25978230da3d7592177bd8b59fdef2c6424798ee8dcdd8677dcf8e92f332fdbf5efc9f696564e82ec4368321debf0bb43c3330e479dd92d45e579cae8963059b SHA512 bf68533b3ff8300cc6bb97fce948172411c4e7ba9dec1c5e69ad0f02dd77e98e838a88cf4b988da9a27cdda2052c7a8b1822d80264695654f61e14dae85ed44a
+DIST firefox-73.0-patches-03.tar.xz 20292 BLAKE2B 0aebef5f4933990bccd5722022b9416393023badb9be29da3a7296e886484d7e937e038e88b85e246879a7d27427b4809d750a652331fb50f3405ef14f776d2c SHA512 5b4ce070b57444c7dd5acccae69eacf5c8bbe51c3ec4b52d1fda6d3d7e465ec22b73453a8bb9e9466fbd77f42bfc3631178e19019d2b1f7b8aa5024a1d4108c5
DIST firefox-73.0b11.source.tar.xz 318682128 BLAKE2B d00e2a451d6491cc889900e117eb636d8e962d9ccf0aa95095e86187b97a76704ad6cbbfe9e97bb06ef001a3dcecd2ace1055e6f28566eaf82134b28c204e067 SHA512 56aac34848aed5bfaf626c83c92c1f3432af00d7fcdb8d152c1bbd1ef35a22bfa84a1715554cccdbb4f7711702bb77a60efec27e14d1ce8368e7f157921a30b3
diff --git a/www-client/firefox/firefox-73.0_beta11.ebuild b/www-client/firefox/firefox-73.0_beta11.ebuild
index 0a72f6b8..884c498d 100644
--- a/www-client/firefox/firefox-73.0_beta11.ebuild
+++ b/www-client/firefox/firefox-73.0_beta11.ebuild
@@ -27,7 +27,7 @@ if [[ ${MOZ_ESR} == 1 ]] ; then
fi
# Patch version
-PATCH="${PN}-73.0-patches-02"
+PATCH="${PN}-73.0-patches-03"
MOZ_HTTP_URI="https://archive.mozilla.org/pub/${PN}/releases"
MOZ_SRC_URI="${MOZ_HTTP_URI}/${MOZ_PV}/source/firefox-${MOZ_PV}.source.tar.xz"
@@ -55,8 +55,8 @@ LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
IUSE="bindist clang cpu_flags_x86_avx2 debug eme-free geckodriver
+gmp-autoupdate hardened hwaccel jack lto cpu_flags_arm_neon pgo
pulseaudio +screenshot selinux startup-notification +system-av1
- +system-icu +system-jpeg +system-libevent +system-sqlite +system-libvpx
- +system-webp test wayland wifi"
+ +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-sqlite
+ +system-libvpx +system-webp test wayland wifi"
REQUIRED_USE="pgo? ( lto )"
@@ -105,6 +105,7 @@ CDEPEND="
>=media-libs/dav1d-0.3.0:=
>=media-libs/libaom-1.0.0:=
)
+ system-harfbuzz? ( >=media-libs/harfbuzz-2.5.3:0= >=media-gfx/graphite2-1.3.13 )
system-icu? ( >=dev-libs/icu-64.1:= )
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
system-libevent? ( >=dev-libs/libevent-2.0:0=[threads] )
@@ -514,8 +515,8 @@ src_configure() {
mozconfig_use_enable startup-notification
mozconfig_use_enable system-sqlite
mozconfig_use_with system-av1
- #mozconfig_use_with system-harfbuzz
- #mozconfig_use_with system-harfbuzz system-graphite2
+ mozconfig_use_with system-harfbuzz
+ mozconfig_use_with system-harfbuzz system-graphite2
mozconfig_use_with system-icu
mozconfig_use_with system-jpeg
mozconfig_use_with system-libvpx
@@ -610,10 +611,10 @@ src_install() {
>>"${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" || die
# force the graphite pref if system-harfbuzz is enabled, since the pref cant disable it
- #if use system-harfbuzz ; then
- # echo "sticky_pref(\"gfx.font_rendering.graphite.enabled\",true);" \
- # >>"${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" || die
- #fi
+ if use system-harfbuzz ; then
+ echo "sticky_pref(\"gfx.font_rendering.graphite.enabled\",true);" \
+ >>"${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" || die
+ fi
# force cairo as the canvas renderer on platforms without skia support
if [[ $(tc-endian) == "big" ]] ; then
diff --git a/www-client/firefox/metadata.xml b/www-client/firefox/metadata.xml
index 0f358be2..b3902c8e 100644
--- a/www-client/firefox/metadata.xml
+++ b/www-client/firefox/metadata.xml
@@ -25,6 +25,8 @@
and <pkg>media-libs/libaom</pkg> library instead of bundled.</flag>
<flag name="system-icu">Use the system-wide <pkg>dev-libs/icu</pkg>
instead of bundled.</flag>
+ <flag name="system-harfbuzz">Use the system-wide <pkg>media-libs/harfbuzz</pkg>
+ and <pkg>media-gfx/graphite2</pkg> instead of bundled.</flag>
<flag name="system-jpeg">Use the system-wide <pkg>media-libs/libjpeg-turbo</pkg>
instead of bundled.</flag>
<flag name="system-libevent">Use the system-wide <pkg>dev-libs/libevent</pkg>