aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2009-11-27 17:45:31 -0600
committerJory A. Pratt <anarchy@gentoo.org>2009-11-27 17:45:31 -0600
commite1a971bc12462b05ee6f6ac9d1b13d682707fbb4 (patch)
tree1e06fb2d3c9e5f8ddef98e52a7ba2c3939f0b5c2 /x11-plugins
parentminor correction to enigmail, include lightning-1.0pre extension support (diff)
downloadmozilla-e1a971bc12462b05ee6f6ac9d1b13d682707fbb4.tar.gz
mozilla-e1a971bc12462b05ee6f6ac9d1b13d682707fbb4.tar.bz2
mozilla-e1a971bc12462b05ee6f6ac9d1b13d682707fbb4.zip
add lightning useflag to thunderbird for calendar support, remove
lightning package.
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/lightning/Manifest3
-rw-r--r--x11-plugins/lightning/lightning-1.0_pre.ebuild110
2 files changed, 0 insertions, 113 deletions
diff --git a/x11-plugins/lightning/Manifest b/x11-plugins/lightning/Manifest
deleted file mode 100644
index de7acbe1..00000000
--- a/x11-plugins/lightning/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST mozilla-thunderbird-3.0-patches-0.1.tar.bz2 3370 RMD160 c8a5a9f4ebcc572ec096574f8d39bb1010273115 SHA1 ae9693a6bb6112b3e97a9fe6603f06ed6b50ee5e SHA256 cdad2899605033df3b5b4abcd1e87d9fc3e46e59f04a3e6833656de0ae2094d6
-DIST thunderbird-3.0rc1.source.tar.bz2 60017712 RMD160 3c5b5a59d59540be9a23192b0d9cd2bc646d9d7d SHA1 5fe37576ece321fc546713330ae83db61f41195b SHA256 1db3513830418eb48f8c433b40d2351d598a9225103afca24cc4a67f3d93ca9d
-EBUILD lightning-1.0_pre.ebuild 2959 RMD160 76c3e56bf43a229c2c52e8d08dca447cd9036414 SHA1 d802caa0bfbd109f9bf225b8037d36115905c0e0 SHA256 8b81f183b04dabd6853d3b683b92becf3af33a4c7c68dd527fac6d6b4df94e5b
diff --git a/x11-plugins/lightning/lightning-1.0_pre.ebuild b/x11-plugins/lightning/lightning-1.0_pre.ebuild
deleted file mode 100644
index c510c546..00000000
--- a/x11-plugins/lightning/lightning-1.0_pre.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-WANT_AUTOCONF="2.1"
-EAPI="2"
-
-inherit flag-o-matic toolchain-funcs eutils mozconfig-3 makeedit multilib mozextension autotools
-
-TBVER="3.0rc1"
-PATCH="mozilla-thunderbird-3.0-patches-0.1"
-
-DESCRIPTION="Calendar extension for Mozilla Thunderbird."
-HOMEPAGE="http://www.mozilla.org/projects/calendar/lightning/"
-SRC_URI="http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/${TBVER}/source/thunderbird-${TBVER}.source.tar.bz2
- http://dev.gentoo.org/~anarchy/dist/${PATCH}.tar.bz2"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-SLOT="0"
-LICENSE="MPL-1.1 GPL-2"
-IUSE=""
-
-RDEPEND=">=mail-client/mozilla-thunderbird-3.0_beta4"
-
-S="${WORKDIR}"/comm-1.9.1
-
-src_unpack() {
- unpack thunderbird-${TBVER}.source.tar.bz2 ${PATCH}.tar.bz2 || die "unpack failed"
-}
-
-src_prepare(){
- # Apply our patches
- EPATCH_EXCLUDE="104-fix_licence_file_preprocessor.patch" \
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"
-
- # Don't strip
- sed -i -e 's/STRIP_/#STRIP_/g' calendar/lightning/Makefile.in
-
- cd mozilla
- eautoreconf
- cd js/src
- eautoreconf
-}
-
-src_configure() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-thunderbird"
-
- ####################################
- #
- # mozconfig, CFLAGS and CXXFLAGS setup
- #
- ####################################
-
- touch mail/config/mozconfig
- mozconfig_init
- mozconfig_config
-
- # lightning-specific settings
- mozconfig_annotate '' \
- --with-system-nspr \
- --with-system-nss \
- --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME} \
- --enable-application=calendar
-
- # Finalize and report settings
- mozconfig_final
-
- # Disable no-print-directory
- MAKEOPTS=${MAKEOPTS/--no-print-directory/}
-
- if [[ $(gcc-major-version) -lt 4 ]]; then
- append-cxxflags -fno-stack-protector
- fi
-
- ####################################
- #
- # Configure and build Thunderbird
- #
- ####################################
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
- econf || die
-
- # This removes extraneous CFLAGS from the Makefiles to reduce RAM
- # requirements while compiling
- edit_makefiles
-}
-
-src_compile() {
- # Only build the parts necessary to support minimial build requirements for additional
- # extensions
- emake -j1 export || die "make export failed"
- emake -C mozilla/xpcom || die "make xpcom failed"
- emake -C mozilla/js/src || die "make js failed"
-
- # Build the lightning plugin
- einfo "Building Lightning plugin..."
- emake -C "${S}"/calendar/lightning/ || die "make lightning failed"
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-thunderbird"
- # Declare emid as sed fails to detect thunderbird emid and tries to use seamonkeys.
- declare emid="{3550f703-e582-4d05-9a08-453d09bdfdc6}"
-
- dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
- cd "${D}"${MOZILLA_FIVE_HOME}/extensions/${emid}
- unzip "${S}"/mozilla/dist/xpi-stage/${PN}.xpi
-}