aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-client/thunderbird/files/thunderbird-60-sqlite3-fts3-tokenizer.patch (renamed from mail-client/thunderbird/files/sqlite3-fts3-tokenizer.patch)12
-rw-r--r--mail-client/thunderbird/thunderbird-60.3.2-r1.ebuild (renamed from mail-client/thunderbird/thunderbird-60.3.2.ebuild)9
2 files changed, 13 insertions, 8 deletions
diff --git a/mail-client/thunderbird/files/sqlite3-fts3-tokenizer.patch b/mail-client/thunderbird/files/thunderbird-60-sqlite3-fts3-tokenizer.patch
index 4e45b139..48ebbf15 100644
--- a/mail-client/thunderbird/files/sqlite3-fts3-tokenizer.patch
+++ b/mail-client/thunderbird/files/thunderbird-60-sqlite3-fts3-tokenizer.patch
@@ -11,6 +11,8 @@ tokenizers enabled by default. This allows to use system SQLite in
distributions which provide SQLite configured in this way (which is SQLite
upstream's default configuration due to security concerns).
+Requires exposing the sqlite3_db_config symbol in bundled SQLite.
+
Disable no longer needed setting of SQLITE_ENABLE_FTS3_TOKENIZER macro in
bundled SQLite build.
@@ -27,6 +29,16 @@ bundled SQLite build.
# Turn on SQLite's assertions in debug builds.
if CONFIG['MOZ_DEBUG']:
DEFINES['SQLITE_DEBUG'] = 1
+--- a/db/sqlite3/src/sqlite.symbols Thu Nov 29 19:08:28 2018 +0000
++++ b/db/sqlite3/src/sqlite.symbols Thu Nov 29 23:02:10 2018 +0000
+@@ -45,6 +45,7 @@
+ sqlite3_create_function16
+ sqlite3_create_module
+ sqlite3_data_count
++sqlite3_db_config
+ sqlite3_db_filename
+ sqlite3_db_handle
+ sqlite3_db_mutex
--- a/storage/mozStorageConnection.cpp Thu Nov 29 19:08:28 2018 +0000
+++ b/storage/mozStorageConnection.cpp Thu Nov 29 23:02:10 2018 +0000
@@ -679,6 +679,10 @@
diff --git a/mail-client/thunderbird/thunderbird-60.3.2.ebuild b/mail-client/thunderbird/thunderbird-60.3.2-r1.ebuild
index 315316cc..b50bc925 100644
--- a/mail-client/thunderbird/thunderbird-60.3.2.ebuild
+++ b/mail-client/thunderbird/thunderbird-60.3.2-r1.ebuild
@@ -199,7 +199,7 @@ src_prepare() {
|| die
eapply "${WORKDIR}/firefox"
- eapply "${FILESDIR}"/sqlite3-fts3-tokenizer.patch
+ eapply "${FILESDIR}"/thunderbird-60-sqlite3-fts3-tokenizer.patch
# Ensure that are plugins dir is enabled as default
sed -i -e "s:/usr/lib/mozilla/plugins:/usr/lib/nsbrowser/plugins:" \
@@ -474,13 +474,6 @@ src_install() {
>>"${BUILD_OBJ_DIR}/dist/bin/defaults/pref/all-gentoo.js" || die
fi
- # dev-db/sqlite does not have FTS3_TOKENIZER support.
- # gloda needs it to function, and bad crashes happen when its enabled and doesn't work
- #if use system-sqlite ; then
- # echo "sticky_pref(\"mailnews.database.global.indexer.enabled\", false);" \
- # >>"${BUILD_OBJ_DIR}/dist/bin/defaults/pref/all-gentoo.js" || die
- #fi
-
cd "${S}" || die
MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL:-${EPREFIX}/bin/bash}" MOZ_NOSPAM=1 \
DESTDIR="${D}" ./mach install || die