aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-01-02 19:45:07 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-01-02 19:45:07 -0500
commit5d24662e2184e08243dec8741eacb80e3eac3a6a (patch)
tree4670eb58c3cb3f3cc6cbfd74c4b6d069d4ffbc2d
parentnet-libs/libtirpc: migrate to sys-libs/queue-standalone (diff)
downloadmusl-5d24662e2184e08243dec8741eacb80e3eac3a6a.tar.gz
musl-5d24662e2184e08243dec8741eacb80e3eac3a6a.tar.bz2
musl-5d24662e2184e08243dec8741eacb80e3eac3a6a.zip
net-libs/libtirpc: add version 1.1.4 from the main tree
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--net-libs/libtirpc/Manifest1
-rw-r--r--net-libs/libtirpc/libtirpc-1.1.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-libs/libtirpc/Manifest b/net-libs/libtirpc/Manifest
index 95af0c27..96612140 100644
--- a/net-libs/libtirpc/Manifest
+++ b/net-libs/libtirpc/Manifest
@@ -1,3 +1,4 @@
DIST libtirpc-1.0.2.tar.bz2 509601 BLAKE2B 7ccf23ca200e2027a66a3105d9b3d0612ac66a08498931f66526a291be6ddef8e7df533af4d44a0e4a1178edd6d51ae39ca50c2536b9b1be7179e7f17cfd165e SHA512 6c819019a8e81d8263d3c509b2eee59ba1ef092222c5a0a8d28f004c711afa252097eca7e6b0b919b2d780883dfd9ee7a363df4cee7fd2c9159a065257637cec
DIST libtirpc-1.0.3.tar.bz2 509831 BLAKE2B 3f908471b3e10f88329793db2c832754b9bb838d115235d7c25256da883960de8d8c94a6941fc9c2a3cc4dca9a77c32b5cb85bb347cc182e5a6255636b79b06e SHA512 1f1cf7dd6f30ddddc919e4caf6db926f1d532f78d5a93e8aaa2acde6b046be0650c4c46549da0ffd5fa7fb9e550af1a871ed6e02ededf504c6667d2e82eba2cc
+DIST libtirpc-1.1.4.tar.bz2 510924 BLAKE2B 1780f9bb0543583c01b60bda681add0ec2f8718eda4ce4653883c772466178e37d0a3fb47004109f81de470129458561fac4f109f45154c64b6fb729f0212c90 SHA512 392f391f9fc1bd68d81dc44e4058831a64b32790b5c8c37338b0ab416fad2ae4d16389e632596734dba09780347918cc65c6f134e0c1afd09e81ec250785ed23
DIST libtirpc-glibc-nfs.tar.xz 8948 BLAKE2B 7316623d9f2b6928e296137fe2bf6794b208d549c2ffba9e4a35b47f7b04bf023798a09f38c02d039debf6adc466d7689cf3c8274d71a22eaff08729642c0a28 SHA512 90255bf0a27af16164e0710dd940778609925d473f4343093ff19d98cc4f23023788bf4edf0178eae1961afc0ba8b69b273de95b7d7e2afdb706701d8ba6f7ba
diff --git a/net-libs/libtirpc/libtirpc-1.1.4.ebuild b/net-libs/libtirpc/libtirpc-1.1.4.ebuild
new file mode 100644
index 00000000..19d4be23
--- /dev/null
+++ b/net-libs/libtirpc/libtirpc-1.1.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal toolchain-funcs
+
+DESCRIPTION="Transport Independent RPC library (SunRPC replacement)"
+HOMEPAGE="http://libtirpc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-glibc-nfs.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/3" # subslot matches SONAME major
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="ipv6 kerberos static-libs"
+
+RDEPEND="kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )
+ app-arch/xz-utils
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.2-bcopy-to-memmove.patch"
+ "${FILESDIR}/${PN}-1.0.3-musl_types.patch"
+)
+
+src_prepare() {
+ cp -r "${WORKDIR}"/tirpc "${S}"/ || die
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable ipv6)
+ $(use_enable kerberos gssapi)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ default
+
+ # libtirpc replaces rpc support in glibc, so we need it in /
+ gen_usr_ldscript -a tirpc
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ insinto /etc
+ doins doc/netconfig
+
+ insinto /usr/include/tirpc
+ doins -r "${WORKDIR}"/tirpc/*
+
+ # makes sure that the linking order for nfs-utils is proper, as
+ # libtool would inject a libgssglue dependency in the list.
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -delete || die
+ fi
+}